My Book Live loses all connections

Hi guys

I see alot of people here are having similar issues. I’m hoping someone can help.

My My Book Live has been working fine (most of the time) until this week. Suddenly it disappeared from my network altogether. I’m using a Mac where I have mounted the Public drive permanently and a WD TV Live Hub where I’ve set the My Book as a network share to play videos (as well as storing all my photos and music collection which Sonos looks to).

In trying to access the My Book again on the network again, I’ve had to unplug the unit completely to try an reboot as the web UI refuses to load.

After connecting the power all seems to be fine, I can view the files from my TV Live Hub, view them via the WD My Cloud desktop app and view them via the mobile app, and the web UI, but have had no luck in connecting again from my Mac. In the last day or two, I’ve been able to stream music ok and watch a TV show saved to the My Book for around half an hour, so I know the files are still there,…before everything stops. Completly. All connections that were once there ae lost. Its always around the half hour mark before I lose connection.

The unit usually displays a flashing green light, then through to solid green, and in the time of writing this, where I’ve lost connection again, there is now a solid amber light.

In this half hour window I’ve had, I’ve managed to assign a static IP to the unit via the web UI in the hope that solved the issue (which it hasn’t!).

I’ve tried to reboot the unit via the web UI, reset the unit via the back of the unit, tried to do a diagnostic check via the web UI (never got past 10% on full diagnostic and 90% on a short diagnostic before timing out), nothing seems to fix the issue.

I’ve since bought a WD My Cloud (and setup) in the hope I can transfer the data across but I can’t keep a connection long enough to copy.

I have around 1.4tb of data on the My Book, including alot of photographs that can never be replaced. I’v seen a few guides that talk through how to retrieve data of the My Book by taking the unit apart, and with mixed results.

Has anyone else had this issue and resolved it??

Thanks for reading


Hi Steve!

I too just ran into this problem today and I was intially freaking out until I somehow got my My Book Live back up long enough to see all my data is ok.  But then it disappeared as quickly as that.  I have tried everything and have been looking thru the interweb and wd forums all day.  If we find anything let’s post ASAP lol

I had a private message saying my issue has been escalated and someone from WD support will be in touch. If anything is resolved I will post.

Get used to it. I am surprised you actually got 1.4TB of data onto it. I’ve been fighting for 6 months to get any response out of WD. Using the web UI is pointless since it will take 2 minutes to load, then another 5 minutes to actually login. Then any action takes another 30sec to 1 min for the next page to load

I can access documents just fine ( via windows exploere mapped drives) , but whenever I try to open any of the folders with pictures it will just hang, until whatever file explorer program I am using just goes unresponsive. I can see by the dates that my WD2Go app and my time machine are still building backups on the WD drive, but I can’t get to them.
I just gave up and learned my lesson that I wasted $100 on a WD drive that stores plenty ,but once you put something on it, you can never get it back.  The flashing green “indexing data” has not stopped flashing for 6 months.
The only thing this HD does relably is send me an email telling me it lost power every time I power cycle it hoping that I can trip it up and get my photo and videos off of it.

Same problem here, although not all but some importent services. My My Book Live is up and running with three services: ftp, afp and nfs. After a reset all services are back (and I can reach the dashboard) but, after some time, (within an hour?) there are three services left. This makes the MyBookLive pretty useless as a NAS. My router is a Cisco EPC3928 placed by my isp. Has anyone found a solution? Send an email to WD but no reaction until now.


i have a simmplar issue but with only one divice my TV.

did anyone learn anything from this post that could help? - Thanks

I m using an HP Laptop PC using Windows 7 Home Pro (latest maintenance).  I have alternated between using a network address or a mapped drive to my My Cloud.  I use a tool called copyto to synchronize files between my local disk and the My Cloud.  I frequently lose connection between the laptop and the My Cloud.  By the time I see the error, the conenction is back up and I can continue synchonizing.  -Mike