My Book Live FTP?

How do you setup My Book Live FTP?

First, create a password for the admin account under “users”, then activate FTP under settings> network> FTP, then make sure port 21 is open on your router.


To use FTP, then open a browser and follow the syntax bellow:




It works for me, but if it does not work for you then you can try the following as suggested by onglh2000 in here.

1 Like

It seems like I’ve tried everything and can’t access my files through FTP.  Here is what I’ve done.

Registered my dynamic IP addy from Qwest with DynDNS.

I’ve also setup port fowarding for FTP (21) to the IP that is assigned to the MyBook Live

I’ve checked the box to allow FTP in the MBL settings and all user accounts, including admin, are password protected.

I can’t get anything to happen.  I need some help.

Check that your ISP is not blocking FTP connections to their customers. You may have to request to have FTP connections allowed in on your account.

1 Like

Hey Mryon,

To answer your question, I have Qwest VDSL (FTTN).  Your comment about blocking made me think to check my router (Cisco E4200) firewall settings and the box that had this for the description (this filter prevents a local computer from using a URL or Internet IPv4 address to access the local server) was checked.

I unchecked that box and voila! LOL  It works now.  Thank you for your help. :slight_smile:

1 Like

It only seems to be working with Firefox 4.  I can’t get IE9 or Safari to open it up using the exact same FTP web address.

By default the VFSTPD FTP server in the MBL allows one connection from an IP address. You need to change this to allow two connections from the same IP address.

Enable SSH if you’re not already done so.  Access the Linux shell and change max_per_ip=1 to read max_per_ip=2 in file /etc/vsftpd.conf``.  Restart the FTP server by using/etc/init.d/vsftpd restart` command. That should cure that one provlem.

I’m not trying the multiple browsers at once.  I can get Firefox and Google Chrome to successfully access the FTP but, IE9 and Safari will not do it.

… but the browser may try open more than one FTP connection to the the VSFTPD service.

I had the same problem. When I allowed two connections from the same IP the problem was was solved.  Try it.  You can but revert the setting to what it was if it does not work.

Remember to restart the VSFTPD service if you make any changes to vsftpd.conf

Well, I had to make some changes to my setup.  To get everything where I needed it to be, I ordered a static IP from my ISP.  So my modem now has that static IP, DynDNS has that IP address.  My modem is now handling routing, NAT, Firewall, etc.  My E4200 is in bridged mode which turns it into a wireless access point.  Now, I can’t login into the FTP.  In FF4, I keep getting “421 Login Incorrect” message.  IE9 asks me for my username and password and I make sure to type it in correctly, and it just spits the login screen back at me.  Google Chrome can’t get anything.  I’m at a complete loss on what is going on.  I’m sure I got port forwarding setup correctly for port 21 and it is being sent to the IP of the MBL.