My Book Live Duo is non-functional after failed firmware update

I just purchased this unit to replace an aging (and failing) Buffalo Terastation, and was eager to get it up and running. As a long-time WD fan (20 years + with no failures) I was expecting the same sort of experience. I’m disappointed, to say the least.

Unpacked the unit, followed the instructions, the initial setup went well. The device was recognized on my network, and after installing the Dashboard I navigated to the ‘Settings’ page to setup my RAID support. This was interrupted by a dialogue that stated a Firmware Update was available. I chose to go ahead with the update. Download was fine; but the firmware update stalled at 10%, and after several minutes a ‘Update Failure’ message came up. The subsequent reboot also failed. The box is now completely useless. Never get a green LED, and it is no longer recognized on the network.

What I have tried:

  • Power cycle (unplug the power) - NO CHANGE, NO GREEN LED, NO NETWORK VISIBILITY

  • Disconnect both LAN cable and power, plug both back in (LAN first) - NO CHANGE

  • Press ‘Reset’ button - NO CHANGE

I have searched the knowledge base and found NO information regarding how to restore this unit, and not received any response to a support case.

VERY disappointed.

It sounds like the update bricked your drive for some reason. Power down the unit and see if the drive will boot if you take out disk A and move disk B into disk A’s slot then boot it up with the one drive in there. If it boots up, shut the unit down and put the other drive back in the empty slot and boot up and see if raid repairs the OS on the other drive. If still a no go…

If you know your away around a computer you can try to debrick the OS by following this guide

Otherwise I would return it to the retailer for replacement

1 Like

Thanks for the response. Apparently the unit is toast (doesn’t boot with the ‘B’ drive in the ‘A’ slot.

I’ve had the exact problem with mine.  I called WD support, and they walked me through the same steps you outline in your post.  When they all failed, they told me I would have to return the unit to the retailer.  I sent it back to Amazon, and they sent me another one that arrived today. IT’S HAVING THE EXACT SAME PROBLEM!  I’m getting ready to give up on WD altogether.  

Where did you purchase yours?  I’m thinking perhaps Amazon got a bad batch?  I told the WD rep I would rather exhange it through them, but they had none in stock (?) and told me I would have to go through the retailer.

Yes, it was Amazon, and I’ve returned mine for a refund. I ordered a Buffalo equivalent (I’ve had a Terastation for fifteen years and it’s finally going away) instead of trusting another WD.

That’s interesting.  I called WD Tech Support on the second unit, and they acknowledged there’a a bad “batch” of these drives out there with this problem.  He told me to call back at the beginning of the week and they will be resupplied - they will replace my 4 TB unit with a 6 TB unit for my inconvenience.  We’ll give it one more try.

Good on WD for responding that way. My old NAS is failing, and every day that goes by is a higher risk for lost data. I’ve been copying critical files off; but one of the failure symptoms is that I cannot copy to a USB drive connected to the unit, so I have to do everything over the network. 2-4 Mb/s transfer rates make for very long copy times when you’re talking terabytes of data. I had to have a unit as quickly as possible. Ordered yesterday, arriving today.

Don’t get me wrong. I won’t buy any other hard drive, internal or external, than WD. Excellent drive products. My old Terastation got upgraded with WD drives about ten years ago, when one of the ‘other brand’ drives failed. RAID saved the data; but I had to replace a drive, so I replaced all four with WD drives (and doubled the capacity at the same time). This box is on 24/7/365, and the drives are still fine after 10 years.

Kindly post your results here after you get your replacement! :wink:

Just had exact problem happen to me after firmware update stops at 10%.  Unit is now non functional.  Just plugged it in for the first time yesterday.  Very frustrating.


I called WD directly after the second MBLD failed the same as the first.  Customer support escalated my issue to Level 2 Spport, where I talked to [deleted].  He was really great, I have to say.  He net-op’ed into my system and didn’t make me jump through a bunch of hoops.  He issued an RMA for the old unit, saying they would prefer to have it so they could examine it, as opposed to returning it to Amazon. He then e-mailed me a pre-paid shipping label to send the old unit back, but not until after I received my new unit. He said for my trouble they would upgrade me from a 4TB to a 6TB unit.  Two weeks passed without receiving my new unit, so I called.  I was told there were no 6TB units in stock yet, but that a manager was going to see that I received a unit before the end of the week.  That was Monday evening.  On Tuesday I received a UPS alert that my drive was sent out via overnight air express.  I received my unit today (Wednesday) at 10 am!  I guess they were out of 6TB units, because they sent me an 8TB unit!  As asked, I called in directly to Level 2 Support and reached Efren.  He was fantastic, and walked me through a manual firmware upgrade. Everything works great!

I was quite dissapointed that I had to go through all of this, but I am EXTREMELY pleased with how WD stepped up to the plate and took care of me.  I’ve always been a huge fan of WD hard drives, and this experience serves to reaffirm my belief in this company.  THANKS WD!

Once again, kudos to WD for responding appropriately. Unfortunately, if I’d had to wait two weeks I’d have lost data (and I didn’t)

Got my first 4tb Duo last Thursday. I also updated the firmware before anything else and ALSO stalled at 10% and never recovered.
Called Amazon on Saturday after WD said send it back after they couldn’t fix the problem over the phone.
Amazon overnighted a new one and got it Tuesday AM.
Last night I installed it, set it up, tried it with iPad and iPhone. All is well except the WD Photos had an error.
Went to update it and…stalled at 10% and is now unresponsive AGAIN.
Now if I don’t get a working 6tb for my troubles that does take an update, I will buy the Seagate model I saw at Costco.
Pisses me off.

How long have you waited?   It’s not unusual for them to sit for 1-2 minutes at 10%, but then usually jumps right to 50-90% after those few minutes.

I’ve updated my Duo numerous times without issue.

I let it sit overnight when after 1/2 an hour passed with nothing but an error message.
Went to Defcon 2 with Sal this morning.
It is being returned for a refund.
Will be picking up a Seagate at Costco.