My Book Essential 3 TB (WDBACW0030HB) and other external drives - avoid 'falling asleep'

I have a number of external USB drives.

Am using them either connected to my PC (drives should not go to sleep then)

or -some of them- with my media player in the living room, in which case I’d like the drive going to sleep.

I cud switch off/unplug the drives there, but my experience is that I’ll forget to do that so the drives will be

up and running all the times (maybe days) until I discover to unplug them.

WDH1CS10000E My Book Home Edition 1 TB
WDE1UBK10000E Elements External USB Drive 1 TB
WDE1UBK10000E Elements External USB Drive 1 TB
WDBAAF0020HBK My Book Essential 2 TB
WDBACW0030HBK My Book Essential 3 TB

Because of the changing situation (PC and livingroom), using Smartware to disable falling asleep is not suitable.

I think, specifically the 3TB drive is causing delay in response from Explorer on my PC.

Q: Is there any other decent solution than Smartware?

Q: Does Smartware change any firmware settings, so that maybe powersave settings from WIndows7 may not have any effects?

Am using Windows 7 x64 Ultimate.



Check if you have any program installed on your computer that might be using the external hard drives.