My Book Essential 2TB Not powering on


#1

I was browsing my files on my external harddrive a couple hours ago when my windows 7 desktop crashed, I restarted my computer and when it came to the part where it was asking for my password, I typed in everything correctly (checked capslock and stuff) and it kept saying invalid password, so I powered off the external harddrive and now it won’t turn itself back on. I unplugged and plugged it back in and all I can see is light at the dot under the lock picture, it’ll start spinning when I first put the power plug in as if it’s starting up and then just go silent after a couple of seconds.

Can anybody help?

ps. I’ve also tried it on my macbook pro, it doesn’t do anything either.


#2

Hello,

Is the drive connected to a power strip? If yes, try connecting the unit to the wall outlet. Also do you feel the drive spinning?


#3

I tried connecting it to a power outlet and it still did the same thing. I could feel something spinning for a couple of seconds and it just stops. When I plug it into the computer, the computer doesn’t recognize it at all and it doesn’t show up on disk management.

I asked somebody else and they said it might be the board that is all screwed up… Is there a way I can change the board?


#4

I am having a similar problem. With mine, I plug it in to the outlet and the light flashes on for approximately 1 second before turning off. It doesn’t even have time to start spinning.