My Book Essential 1.5 TB not being recognized at all

Up until now My Book has been working fine. 

Recently, it stopped being detected by my computer. 

The My Book Essential turns on when plugged it, and does not flash at all. When I press the power button on the back, the drive loads up and there is a light that never blinks. 

I tried connecting to my computer, but it’s not even recognized at all. It doesn’t even make the sound when an unknown device is plugged in. It’s as if it’s not even plugged in at all. Of course, I tried all USB port slots, as well as on 2 other computers with ALL usb ports and to no avail. 

My guess is the plug isn’t working at all, but it seems perfectly fine to me. 

 However, I guess it can be said that the USB 3.0 cable is somewhat loose, but fits in perfectly. Is there a way I can tell if my drive is not working? As if the connector doesn’t work for the drive? Like I heard in other threads about the “usb port” being broken from the circuit board. 

And if it is, is it possible to recover the files through other means? 


HI there, recovering the files depends on the type of drive… What exact model is it?

Do a little bit of troubleshooting:

  • Replace the USB cable

  • Test the drive in a different computer

  • Change the power adapter

My Book 1TB, have same problem…tried everything… but still unable to access the drive…

I think the quality of these drives have a big ??? not reliable… not worth spending money on…

am dissappointed in WD product quality