My Book Duo in Raid 1 - Solid red status light and one flashing drive light

Hi there, I own 2 My Book Duo, one 12GB and one 16GB. Yesterday I found the 12GB (6GB in Raid 1) not mounting. Restarted the drive and the status light flashed slowly. All drive tests showed no problem but raid status said unable to access data.

Since I got 2 enclosures I swapped the drives to the other one to test and got the same result so there was not problem with the enclosure. I also tried to take out one of the drives and unable to mount it. I’m now running out of options and any suggestions are welcomed.

Have you try the WD Disk Utilities app see if it can tell you anything. Solid red status light mean Raid is degrade or drive is not configure. If one of your drive is bad, you should see a red light LED on for that drive. But use the WD disk utilities see it can tell you anything first.

Thanks for your advice. I had tried WD Disk Utilities. It said Raid was degraded if I pull one drive out but it didn’t mount regardless. Decided to format and I could format only one of the drives. The other didn’t work, both reconfigure RAID as well as format. There was no clicking sound or any abnormality on both drives. I’m using the enclosure with my Mac and will try formating the faulty drive on Windows.

I have been using Backblaze to backup my data but I didn’t aware the drive had been offline for a long time. The backup is now gone and fortunately I had some data backed up locally with a My Book Element but I don’t really have an idea that what is lost.