Mount SMB share on PR4100?

#1

I’m trying to mount a handful of shared folders from devices around my network on my PR4100 (rather than mounting PR4100 shares on those devices).

So far, I’ve been trying the following:

mount -t cifs //192.168.1.98/test /mnt/test -o username=xyz

…which produces the following error:

mount: block device //192.168.1.98/test is write-protected, mounting read-only
mount: cannot mount block device //192.168.1.98/test read-only

I should note that doing the same with 192.168.1.98/non-existent-share gives the same error message.

I’ve also tried to just get some info with

smbclient -L 192.168.1.98

… but that falls over with

WARNING: The "null passwords" option is deprecated
WARNING: The "use spnego" option is deprecated

Does anyone have any experience with this?

#2

Warnings are not failures…
The error says that the remote device is write-protected, so you should look on the remote device first.
I’d suggest to use NFS mounts, it’s a bit easier.

To get rid of the warnings, comment the options in /etc/samba/smb.conf.
Note: this file gets restored on boot.

#3

@Tfl the named share on the remote device is set as R/W for everyone, and in fact the PR4100 shows the same message even if I attempt to connect to a non-existent share, so I’m wondering if there’s something a bit deeper going on?

#4

From https://wiki.samba.org/index.php/Mounting_samba_shares_from_a_unix_client

mount -t cifs //192.168.1.98/test /mnt/test -o username=xyz,guest

Maybe dmesg could help too.

What OS is running on the box? Can you connect via a regular Ubuntu machine?
Try passing the user to smbclient.