Mounting mybooklive to pr4100

I have my p4100 set up and it’s been working fine since august. I also have a mybooklive that I have mounted for some extra plex storage. It recently rebooted and I lost the mount mapping and I cant figure out how I did it before. ive tried a few different mount commands and adding an entry to the /etc/fstab file to no avail.
for exampe Ive tried

sudo mount -t cifs -o user=name ,password= ***** //MYBOOKLIVE/Public/!Videos /shares/Public/mbl_vids

Any help is appreciated.


Might help if you post any errors generated by the commands you’re trying…

Don’t have the PR but for me it works the following for mounting an NFS share from a My Cloud into an EX2.

busybox mount -o nolock,ro,hard,intr,vers=3 -t nfs

1 Like

this is the error im getting
mount: wrong fs type, bad option, bad superblock on

Ive tried both cifs and nfs

dan_sp - I’ve been looking for quite a long time to find some way to mount an NFS share from my EX4100 onto my PR4100 Plex server. Your post had the magic key.

I’ve typed up some notes to help anyone else in this type of situation avoid some of the issues I’ve had, that happens to stumble across this thread. Hopefully, I haven’t left anything out.

  1. Set your source device to a static IP
  2. Turn on NFS on the source device
  3. Create a share on the source device (in my example, it’s called “PlexMedia”)
  4. Turn on NFS on the share you just created
  5. Write down what the Mount Point is called (in my example, it is “nfs://”)
  6. Take a deep breath. You’re half-way there.
  7. Turn on SSH on the target device
  8. Install PuTTY on your computer
  9. Use PuTTY to log into the target device
  10. Type “cd /mnt/HD/HD_a2” to get to the folder where shares are located
  11. Type "mkdir " and the name of what you want the new share to be called (in my example, it’s “EX4100”)
  12. Type “busybox mount -o nolock,ro,hard,intr,vers=3 -t nfs /mnt/HD/HD_a2/EX4100” (where and /nfs/PlexMedia are from #5 above, and EX4100 is from #11 above - don’t overlook the “:” between the IP address and the share name)

Instructions on how to use PuTTY to get into a PR4100 can be found reasonably easy. Remember, Linux is more case-sensitive than Windows / DOS, so keep that in mind when you’re in PuTTY.

When you’re in Plex, to get to the new share folder in the Add Folder dialog, you’ll have to navigate to the “/mnt/HD/HD_a2/” folder, and then to the name of the new share you’ve created - the new share folder doesn’t just show up in the list of folders on the left. If anyone knows how to make that happen, please feel free to share.


Great, i just solved my issue with your Tips…
Thank you

After long long time, thanks. You solved my problem on my MyCloudEX2Ultra.