Media not secure in private share?

I’ve been using the WD My Cloud for a while to store a variety of files including media (video, pictures, music, etc) but have always kept the share private to prevent others from accessing the data.

However, last night I found out that a friend’s phone (Samsung Galaxy S5 if that matters) was able to access all of my media just by searching for local devices.  They ARE connected to my local internet but I had never registered their device nor did they need to enter the user name and password that should have been required to access this information.

Turning off Media Serving (either for that share or for the entire device) fixes the issue and they can no longer see any of the media.  However, when I try to access it with my user (full permissions) on my desktop through a Windows 7 explorer, I can’t see anything except a single SWF file.  Everything else disappears. 

I’ve tried restarting the WD My Cloud as well as my computer but the results remain the same.

Is there any way to allow computers that have input the user information to access content on the WD My Cloud but NOT have random mobile devices on the same network being able to access the same thing?  This is a rather big security issue for me.


They are accessing via DLNA.

DLNA does not respect permissions; that’s a DLNA spec issue, I’m afraid…

So is there no way to keep media secure but still accessible to those with the proper permissions then?

Kind of defeats the purpose of having a private share if everyone can access it and turning off the DLNA makes it impossible to access even for me.

Don’t access it via DLNA; access as a network drive, e.g. using Kodi and SMB access.

The blame lies with the DLNA Consortium in this case, not WD.

ps. We’re all customers here, not WD staff.

Yeah, I tried accessing it via a network drive and logging into a user that has access, but as soon as I turn off the Media Serving it completely removes all the files and I can’t see anything on the drive anymore (well, except the single SWF file).

And I understand that we’re all customers here, just wondering how other people got around this.  I do appreciate the help so far :slight_smile:

 as soon as I turn off the Media Serving it completely removes all the files

That suggests you’re still using DLNA to access, not SMB. SMB should access as a network disk, and be unaffected by the media serving setting.

Just checked: turned off media serving on Public, and Kodi is still able to access via SMB. My only doubt is that I tried Public, not a private share…

Maybe it’s the way I mapped the network drive then.  I’m not at home now but I’ll try turning off the Media Serving and playing with the connection to see if I can get it fixed then.  

Thanks for the tips.