MBL doesn't enter sleep mode while Remote Access is enabled

The new firmware (02.32.05-044) has the same bug as the one before: MBL doesn’t enter sleep mode while Remote Access is enabled.

The surprising thing is that initially, after I purchesed MBL a few months ago, sleep mode worked fine. But then suddenly this problem started. I’m really not aware that something relevant would have changed then, neither in the MBL setup nor in my network infrastructure. Initially, I set up MBL for backups and as a mirror for my photo & music collection.

I’ve got the same problem since the last update.

Please make a new release!!


So have I , mines just an expensive external HD now since disabling remote access so I can get the drive to sleep. You may not have seen the announcement in the firmware update thread but WD have taken down the firmware update due to remote access issues.

I was also having this problem, but I found out that something called Miocrawler was causing the problem.

The solution was to add an extra line to the file miocrawlerd, which is located in the directory /usr/miocrawler/ of the MBL as described  here.

To see if Miocrawler is the problem you have to login to the MBL and type the command: top, which shows the processes occupying the CPU the most.

This is what I did in details:

  1. enable SSH_ _in the Dashboard. It’s explained in  this thread

  2. log in to the MBL using the program PuTTYExplanation (use the ip-address of the MBL as the host name)

When PutTTY’s black window opens then log in as _root _using the password welc0me.

  1. type the command: top to make sure that Miocrawler is the problem.

  2. navigate to the right directory by entering this command: cd  /usr/orion/miocrawler/

(to find this directory I used the Process ID of miocrawler and the directory /proc/(processid)/ and the command ls -l )

  1. open the file miocrawlerd with the nano-editor: nano miocrawlerd

  2. write the extra line:

exit 1

as the second line of the file (just after the line #!/bin/sh)

  1. save the file (Ctrl+O) and quit the editor (Ctrl+X) and close the putty window.

  2. restart the MBL using the Utilities section of the Dashboard.

The miocrawler’s function is to prepare the stored image files to be shown on smartphones, by resizing them. It is apparently a very slow process because I have about 70 GB of photos on my MBL, but 2 weeks wasn’t enough for the miocrawler. I doubt that it would ever end. Therefore I disabled it as explained above.