Lots of problems, lately

#1

My problems started with the same issues others on Windows 10 are reporting: can no longer browse to the drive using \drivename\sharename, as I’ve been able to do for years. I’d go through some of the fixes found here and it would work briefly, but there’d be a different problem, next time.

Now I’m noticing issues with accessing the UI/dashboard – it’s just REALLY slow.

So I thought - let’s update the firmware. The firmware won’t load. I can’t do a manual or other method firmware update. Nothing happens.

What’s going on ? Is the software for this drive causing it to slowly go out of function? That’s kind of what it feels like. Does WD read these forum posts? I have important data on this drive and, because it’s the biggest drive I own, no easy way to back up the data on this drive.

#2

More information is needed. What firmware version My Cloud do you have? First gen v4.x or second gen v2.x single bay/single drive My Cloud?

Has anything changed recently on the local network? New broadband provider, new router, etc.

Is the problem confined to one computer or mobile device or is the issue happening to all local network devices.

When it comes to slow Dashboard, have you tried using a different web browser? Some security software/malware/antivirus software may impact web page loading. Same goes for browser extensions/add-ons. There are some that may impact loading the Dashboard.

This is mostly a user to user support forum. If you want/need dedicated WD support then contact them directly via the WD Support link at the top of the page and open up a troubleshooting case with them. Rarely do actual WD Staff respond to posts these days in this subforum.

#3

Not a Window person, but have you tried using the IP address instead of the drivename \192.168.1.2\Public? It may be an issue with your network or with changes to Windows that may have affected how you connect.

#4

Sorry - haven’t had a chance to mess with this much lately but, today, I was on it and getting really frustrated. Then I found your reply, browsed using the IP address, and it’s fast and accessible.

What would cause this? How do I get back browsing by name if browsing by IP works fine?

And why is the WEB interface (which I access using the IP address all the time) so damned slow or non-responsive, suddenly?

I appreciate your help. I need to get this fully resolved. I’ve got important stuff on this drive and am starting to think I need to get it off.

#5

Unfortunately,this doesn’t work consistently. After restarting my laptop this morning, I can see my drive listed in Windows 10’s “This PC”, but cannot access it in any way. The WD Smartware/quickview doesn’t seem to know it’s there. I have an IP Scanning software and, if I run that, I can use my browser software to view contents via FTP, but that doesn’t help me. Trying to browse to the drive after that FTP access seems to be trying, but it just hangs my File Explorer windows. I need to access my drive like it’s a drive on my computer, and my My Cloud is just not working to help me do that, lately. I’d really like to know why, so I can resolve this. How do I get help from WD for a years-old product?

#6

Your problems may be caused by how your MyCloud, laptop and/or router are configured. Again, I don’t know Windows, so “This PC” does not mean much to me. I don’t use the WD Smartware either.

MyCloud Settings:

  • General > Device Profile > Device Name - make sure you have a name or change to something easy (such as NAS :wink:
  • Network > Network Services > Network Mode > DHCP - this means your router will assign it an IP address (such as 192.168.1.200)
  • Reboot - lets the router get your new settings

Router settings (generic since I don’t know what model you have):

  • LAN > Device Name - give it a name like router
  • LAN > DHCP Server > Domain Name - give it a name like lan or home - DO NOT USE local !!!
  • Apply, then Reboot

You should be able to find MyCloud in your browser any of these:
ftp://NAS.lan/Public or ftp://NAS.local/Public (for the files)
smb://NAS.lan/Public or ftp://NAS.local/Public (for the files)
http://NAS.lan/UI or http://NAS.local/UI (for the login screen)

#7

Sorry - returning again because this problem resolves, stays resolved for a while, then comes back with a vengeance for no apparent reason.

Firmware is v04.05.00-327. I’m not sure how to know what generation or how many bays I have - I bought this thing AGES ago. I’m assuming it’s sngle bay, but no idea what gen. S/N is WCC4M4CS7798 if that helps. Nothing has changed RECENTLY on the network, but I do have 2 routers, one acting as a bridge, and I’m knowledgeable enough about routers only to be dangerous. The only changes I’ve made on the routers are to try to get a nearby wifi camera acting correctly. Only one computer accesses this drive regularly, and that’s the Win 10 notebook I’m using now. My browser is Opera, but I tried Edge and it is a little faster / more responsive.

Regardless - the continuing problem is access to my drive’s contents from a Windows 10 PC. I cannot always browse to it – but sometimes I can. I have a static IP for the MyCloud, and I used to be able to browse to its name, then had to switch to its IP, now can’t get to either. “Windows cannot access…”

#8

My WD device has an easy name: dhdrive. My WD device has a static IP address.

My Router (a Dlink DIR-882) local management link name, but I cannot find the “device name” setting and don’t understand the “Domain name” setting enough to change it, right now.

When I type ftp://dhdrive.local/Public: “Can’t reach this page”
When I type smb://dhdrive.local/Public: I get weird google search results
When I type http://dhdrive.local/UI: “Hmmm…can’t reach this page”

#9

According to pg 58 of the manual for your router, you would set your local domain name under: Settings > Network > Advanced Settings > Local Domain Name.

Have you tried opening a command window on your PC to ping your WD NAS?
ping dhdrive
ping dhdrive.home (after you set the local domain name on your router to “home”)
ping dhdrive.local
ping 192.168.1.X (whatever your static IP is)

All of those should work if your network is configured properly.

#10

Ping dhdrive fails
I’m not changing my domain name until I understand how it affects all of my connections.
Ping dhdrive.local fails
ping ip address works fine. Can’t browse to that anymore, though that had been working well for some time.

I have a windows app called Advanced IP Scanner. It finds the device on my network, sees its dhdrive name, and allows me to browse via FTP. Works fine. Also lets me browse via http. Works fine. The only thing that doesn’t work fine is windows/network browsing, which worked for a long time, stopped working probably around the time that Microsoft dropped SMB support on Win 10 (or whatever they did) – and now has worked on and off unpredictably.