Lost MyCloud access from Win10 (Android access ok)

Hi,

Have MyCloud Mirror 6TB connected to router on home network, and during lockdown have been remotely accessing my share files via both Win10 laptop and Android devices via MyCloud software - steady as a rock from March to Sept

Last couple of days I managed to get home, and did the latest updates to Win10 on our desktop PC, and the software on the Cloud device

Since then, I can still access the share files from Android devices, whether at home or remotely. But both the desktop Win10 PC (on same network as the Cloud device) and the Win10 laptop (remote access) have lost access. I have tried to reconnect MyCloud using my login via MyCloud.com, and using access codes, but everything fails, access denied

At home I can still access the device from the desktop PC as Admin to generate the access codes

I’m baffled about what’s changed - Any advice would be appreciated to help me re-establish access to my share from my Win10 devices!

Regards,

Alan N

Hi,

You could refer to the following link: https://support-en.wd.com/app/answers/detail/a_id/9323

Check this tips i collect…

Network Discovery

Enable Windows Network Discovery
For instructions, please refer to Answer ID 18218 How to Enabled Windows Network Discovery
:::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::

Ensure the following Windows Services are running and set to Automatic.
Please follow the steps outlined below this list for instructions on how to make changes if needed.

Type services.msc from the search bar as shown below

Computer Browser
DHCP Client
DNS Client
Network Location Awareness
Function Discovery Resource Publication
Plug and Play
SSDP Discovery
Storage Server
Server
UPnP Device Host
TCP/IP NetBIOS Helper
WD Backup
WD Driver Manager
WD Driver Manager Service
Workstation

check and enable this too:

***** To fix this problem I had to turn on Enable insecure guest logons using Local Group Policy Editor. Open gpedit.msc, select Computer Configuration, Administrative Templates, Network, Lanman Workstation. Change the setting of Enable insecure guest logons to Enabled. ********************************************************************************

Here is what I just found with a Google search and it worked for me.

Open the Control Panel select Programs and Features then open Turn Windows features on or off
then make sure the following box is checked, SMB 1.0/CIFS File Sharing Support, your computer will have to reboot for it to take affect.
See images below, click on, tap or activate images to enlarge them.

activate this too:

This policy setting determines if the SMB client will allow insecure guest logons to an SMB server.

If you enable this policy setting or if you do not configure this policy setting, the SMB client will allow insecure guest logons.

If you disable this policy setting, the SMB client will reject insecure guest logons.

Insecure guest logons are used by file servers to allow unauthenticated access to shared folders. While uncommon in an enterprise environment, insecure guest logons are frequently used by consumer Network Attached Storage (NAS) appliances acting as file servers.

#######################################################

Alan, did you get this figured out? I can connect with cloud or ethernet cable but not on home wifi network. I tweaked the SMB setting as someone suggested, but did not mess with all those services.