LOST DATA - WD 1Tb not working - volume config mac - erase

Best WD Community,
I’ve got some big troubles with my WD drive.

Did it into my Mac and it doesn’t appear.
So I Googled some things (but didn’t read very well), did some other stupid things and now…
My drive is formatted, empty and my whole digital life in photo’s and document from the past 8 years is gone…

Wondershare is running to look for old or damaged partition… but no succes.

Do you have an solution?
I really hope you can help me with my stupid accident :frowning:

Hey Bridt172,

Sorry to hear that, i know how it feels but don’t panic, i had similar problems before but at the end the data were still on the Drive.

Here are some question that might be helpful to you and us:

- Were you able to use the WD Drive on the same Mac before? Or it is the first time on this Mac?

- Were you using the WD Drive recently more than a few days? or you had it unplugged/turned off for a while?

- Does it show an error like “Your drive isn’t formatted” when you try to open it?

- Did you try restarting your Mac?
I had this problem in the past many times and all i did was a system restart and the Drive showed up with all of the data intact.

- Have you always used your WD Drive on a Mac? or you used it on other Computers like Windows?
If you plug the Mac formatted Drive into a different computer like Windows, it will show as the drive is empty and needs to be formatted and vice versa.

Sorry if I’m not much of help, hopefully someone else can help you get your data back :disappointed:

Hey, SoftDisk,

Thank you for your reply, im curious about what you have tried to fix this problem. First i restarted my mac, but there was no data available on the drive. I answered all of your questions below with caps lock.

I hope to hear from you again!

Hey Bridt172,

Sorry for the late reply, I’m sorry but for some reason i can’t see your answers posted.

In my end, all i did was a restart, but the issue i had was actually because of a USB Hub, it was not providing enough power to the Drive.
And the problem was i couldn’t access the drive, it kept saying (Do you want to format the drive?)

Sometimes a restart solves this, but it’s always better to buy a new USB cable or a better USB Hub, so you should try a different USB cable if you can’t access the Drive.

I recommend DriveDX and the additional SAT-SMART drivers for USB. This both will help to detect failures.
http://binaryfruit.com/drivedx/usb-drive-support (here are singed drivers)

The SAT-SMART driver project

I lost all my data and thankfully my search found it’s way here. I read SoftDisk’s reply to Bridt172 and immediately restarted my machine and boom! the data magically reappeared. I reply here so that anyone coming across this may do that first as well. Good day!

Data recovery from a troubled Mac hard drive is challenging. it may or may not work. Please go through below. You said:

1) Did it into my Mac and it doesn’t appear.

1.1) Does it appear in Disk Utility?

2) My drive is formatted, empty and my whole digital life in photo’s and document from the past 8 years is gone…

2.1) Formatting is a usual case of data loss. You said: didn’t appear? A formatted hard drive should appear if it has a working file system. Can you check the file system on your external hard drive?

3) Wondershare is running to look for old or damaged partition… but no succes.

3.1) Now again, you mention that disk is troubled and somehow data recovery tool is not working. I take it as a troubled hard drive too. Have you tried any other data recovery application? I recommend you do Stellar Phoenix Mac Data Recovery software. They have multiple features for advanced data recovery:

a) Searching lost and deleted partitions

b) Raw Recovery for data recovery from corrupt disk

c) Creating disk image file and later doing recovery

My experience say you must try it https://www.stellarinfo.com/data-recovery-mac.php

Also, please be aware that any software that is about to recover hard drive data must list up your partition or hard drive for further processes. In case the drive remains invisible from the desktop, disk utility or from the software then the drive have severe file system corruption or component failures.

[Update: Didn’t realized that the original query was 1 year older. Anyways, I think my reply is still helpful for other users]

Some time ago, I had a crashed HFS+ partition. No chance to repair with macOS tools.
But under Linux with Linux HFS+ driver I could read this partition and copy some files from it.

I use another recovery tool in trial version - Data Rescue
Data Rescue tells that the personal datas could be recovered, but at last I use the last TM backup.

Data Rescue
https://www.prosofteng.com/data-rescue-recovery-software/

One of the Best USB Data Recovery Software for Windows which I know are

  1. Recuva Data Recovery
  2. Disk Drill
  3. Pandora Data Recovery Freeware
  4. Photo Rec Data Recovery Software
  5. Glary Undelete
    source:- http://merabheja.com/best-free-usb-data-recovery-software-for-windows/

I know this is an old post, but I’m going to respond anyway, because someone else might find this info useful and applicable in 2022. I have tried Data Rescue in the past with great results if I recall correctly. But, GetMyDataBack has been the fastest, easiest, and most accurate recovery tool I that I have come across, and it was free back then, not sure how much now.

Before you get all excited and start trying all types of recovery software on your drive, you should know that you must avoid using the corrupted drive in order to save what is left of the data without causing more problems. The more you use the drive, the more likely that you will cause additional damage to the data and the file system.

The best thing you can do to save your files and limit potential loss of data, is to create an identical clone or disk image to backup your drive. Then, work on repairing the disk image instead of repairing the physical drive.

Based on my experience in the IT field for years, the majority of drive failures that I have seen were related to corruption of the drive’s partition table, not the actual file system. In other words, there is a great chance that your data is still intact, because partition tables, in simple terms, is like a map to that helps guide your system to access your files. Losing the map to your destination doesn’t mean that the physical location was also “lost”, you just lost your way to to get to your destination thats all. Repairing the partition table is similar to repairing or finding a new map to your destination.

You can rebuild the partition table using basic terminal commands in macOS, Linux, or even Windows, and can usually accomplish in less than an hour. Just research how to rebuild GPT, MBR partitions as a head start.

More Technical explanation:

  • Partitions are contiguous sections of a hard disk, identified by sector numbers, such as sectors 2,048 to 41,943,040. Partitions are defined in a data structure called a partition table, which is simply a list of sector ranges and some simple associated data (such as a type code to identify the type of data the partition contains). Two common partition table types are MBR and GPT.

  • Filesystems are much more complex data structures that enable storing, organizing, and locating individual files on the disk. Filesystems are often stored inside partitions, which simply means that they occupy the range of sectors identified by the partition table as being a particular partition. Numerous different filesystems are available, such as FAT, NTFS, HFS+, ext4fs, and so on.

Thanks to klanomath from stack exchange, here is one of his examples on how to repair GPT partition on macOS. Don’t try this without first investigating the problem associated with your particular drive.

Only use this if you know what your doing:

To correct the GUID error in your GPT, you need to start up from OS X Recovery over the Internet or from a USB drive with the macOS Installer flashed on it. To boot into recovery mode press and hold the command(⌘)optionR keys immediately after you turn on your Mac and hear the startup sound. To boot into a USB key, hold option immediately after you turn on your Mac. You will be prompted to select a drive, one of which will be titled something similar to “macOS Installer” which you will need to select. Once started to OS X Recovery or the Installer, select the Utilities Menu, then click on the Terminal application from the menu bar. Enter the following commands one at a time and press enter after each command to repair your GPT.

diskutil  unmountdisk  /dev/disk0
gpt  remove  -i  2  /dev/disk0
diskutil  unmountdisk  /dev/disk0
gpt  add  -i  2  -b  409640  -s  194016208  -t  hfs  /dev/disk0