Logon to the dashboard times out after 15 seconds

After updating to the latest firmware, I could not log on any longer to the dashboard. After keying in username/password, the system blanks the loginfields and returns after approx 15 seconds, that „login timed out, please logon again.

I reset the device. After reboot finished, I noticed that the password field greyed out but still no logon possible, as the sam behaviournas before.

I run the My Cloud Mirror, 1st generation, P/N WDBZVM0040JWT-20

Any helpful hint is welcome

Hi @ufrach,

Please select and use one of the solutions to work around the Login Time Out issue

  1. If using a safari browser, update the safari browser to version 13 or mobile devices to iOS 13.
  2. Use the IP address of the My Cloud instead of the .local domain to access the dashboard.
  3. Use an alternate web browser such as Firefox or Chrome on macOS computers.

Good Morning
Thanks your hints, like to comment as follows:
ad 1
Used already iOS 14.x.x respectively macOS 11.5.2
ad 2
Used IP
ad 3
Used Firefox

all above did not do any better but found following strange behaviour on FW 2.12.127 which was loaded and reported beeing actual
Logon 1 - timed out
Logon 2 - using an additional tab win same browser opened the dashboard wout prompting for unam/pw.
No tiomeout occures

Weited, isnˋt it