Last week 2TB Passport shows up in Devices & Printers and Device Manager, not My Computer anymore

Bought a 2TB Passport February 2016. Last week it stopped being detected where it normally is.

External HDD shows up in Device Manager and Devices & Printers as an external HDD, but not under My Computer/Devices with removable storage.

Hard drive is normal sounding. No errors or warnings anywhere.

  1. Uninstalled drivers and reinstalled them.
  2. Tried multiple USB 3.0 and microUSB cables on multiple USB ports.
  3. Tried multiple computers (2 Windows 7 laptops, 2 Windows 10 laptops, 1 Macbook)
  4. Checked disk management. It says that ‘Disk 1’ isn’t initialized and asks me if I want to initialize via MBR or GPT. However I do not want to lose my data, so I can’t initialize it and assign a drive letter.
  5. Removed the hard drive out of its enclosure to use its SATA port. Unfortunately there is no SATA port, just a USB port.

There were no changes made between the day that it was working and the day it stopped working.

Try to follow the steps mention on the link

https://www.easeus.com/resource/retrieving-data-from-disk-unknown-not-initialized.html

I am facing the same issue, this step doesn’t help

Facing the same issue