It just stopped recognizing content on attached hard drive

I have what I believe is a 1st gen WDTV Live Plus. It has worked great for a couple of years. I went to play something and it did not recognize the hard drive that is attached by USB. Everything turns on, it looks like it should work, but it does not recognize the attached hard drive. I am not an expert. What would be my next step. I am thinking of trying to update the software but all that is available is for the 3rd generation. Any feedback or guidance would be greatly appreciated. Thank you

What size/capacity is the hard drive that you are trying to connect?

HELP! I am on a U.S. Navy Warship in the North Pole. We ordered and finally received the WD 1TB Media Player we have been anxiously waiting for. It arrived and we quickly filled it with videos which was our primary purpose. The only problem is that we are trying to organize them, edit the folders and when connected to a laptop, the laptop doesn’t recognize the 1TB drive at all !!! How do I fix this!? Obviously, up here at the North Pole, we have LIMITED LIMITED LIMITED bandwidth and barely being able to post this. PLEASE HELP US!!!

First of all, thank you for replying.

I have a My Essentials 1TB hard drive connected to my WDTV. It worked for a long time. One day the hard drive was not recognized. The only options under video are now Media Servers and Network Shares. I can tell the two units are connected because my WDTV turns on and then it turns on the hard drive like usual. I can see the lights come on in sequence as usual but I can’t navigate to the files on my hard drive. I am not connected to any network, I just use it to watch movies, the units are isolated and free standing. I can get to the UI for the WDTV so it is frustrating.