Issue with wifi dongle

I’m using a Belkin N+ 600 DB router and Belkin N150 wifi dongle which are being used for the WDTV Live which I have.

The router has a USB port to which is attached an external USB drive of 1TB. I have various video and music files there which I’m trying to play via the WDTV.

This setup worked perfectly for a few weeks. But then a weird problem arose. The WiFi dongle which is attached to the WDTV Live suddenly started acting strangely. When I tried to setup a wireless network, it rarely detected my router’s WiFi signal and even when it did the signal bar indicated that the signal strength was very weak (1/5 bars or sometimes no green bars in the signal area at all). I then tried to find out if there was something wrong with the dongle. I connected it to my laptop and it worked perfectly. It detected every signal and connected to networks just fine. I was then suspicious of the area where the WDTV Live was kept. I took my android phone and tried to setup a wireless network just from that particular spot. However, my phone was able to connect to my router perfectly from that very spot that too with a full signal strength. I was then concerned about the WDTV Live’s condition. The USB port I tested was OK. It detected and played every video and audio file from a pen drive. And when I attached a LAN cable from my router to the WDTV Live, I was able to access the 1TB hard drive which is attached to my router and play videos and audio files from it perfectly.

I am a bit stumped at this stage. I have tried the power cycle and the reset options, but none of these has really worked.

It would really be great if someone here could help me out in this regard.

Thank you.

Hello mate, try moving the WD TV closer to the router and check if you still get low bars. If the problem continues roll back to an older version of the firmware and check if it stays the same.

1 Like


I would have tried rolling back the firmware but none of the download links on that page are working. Is there somewhere else I could download the firmware from?

–oops sorry, links are working now, must have been a google chrome issue. i’ll let you know if things work out.


okay. something outright strange just happened. no solution was working and no matter what permutation and combination i tried regarding resetting the wdtv and the router, everything was getting stuck.

finally, when i’d almost given up and i was trying setting up a wireless connection for the very last time on the wdtv, the modem’s internet connectivity was lost and the router came up with the red light indicating disconnection, the network setup worked! when internet connectivity returned and the router light blinked blue, i found that everything was working properly. even the signal strength has returned to normal. really dont have a clue as to what had gone wrong and what made it right.

but thank you for the help!