Issue with 4TB my passport WD

Hi,

I have issue with my 4TB my passport WD external harddrive. ( I checked that I still have 3 TB free space and the system is confirmed NTFS )

The problem was started last night, after I copied a big files (like 25 gigs). The copy process was success.

  1. When I want to copy any file from my C drive, the copy process stuck at 0% , and it says "could not read from specified file / disk ".
    I tried to copy any file from my C drive to another drive , it works. So that means the WD ext hard drive has issue.
    I can copy any file from this WD ext hard drive to my C drive without issue, but NOT the OTHER way round.

  2. When I tried to delete a file from this WD ext hard drive , it can be deleted but when I refresh the file magically Re-appears.

–> I have tried to run disc check , but return error message said it could not be done
–> I have tried to run chkdsk /f , it also failed at 3rd step " insufficient space to write $J blabla"

Please help me.

don’t know what the problem could be, but try running WD’s Data Lifeguard Diagnostic for Windows