Is there a way to perform a factory reset on a WD Drive? Raid Issues

Hello all,

I had a series of 4TB WD drives in a Synology NAS raid 5 configuration. I swapped them all out for 8TB drives, which was great, however, when attempting to format the 4TB drives after the fact (external USB dock), I ended up with a single 1.67TB partition that I have not been able to resolve. I have researched this for several hours today, and attempted everything that I could with DISKPART, etc, to no avail. Any tips or methods of resetting these drives to original size?

Windows 10 OS

Thanks everyone!

1 Like

Have you try to Diskpart then “select disk #” you want then “clean” that drive. That might get all the space back to it original size.

Yes, that is one of the first things I tried, to no avail. It’s almost like the Synology raid configuration performed some voodoo that will not undo itself under windows. Any other thoughts from any other experts?

You might want to check with Synology community website or their support website. You are posting your question in here that is a sub forum regarding WD Surveillance drives issue only. You might want to ask this question in WD hard drive forum

Will do. I could not find the WD Hard Drive forum. Thanks for the feedback.

Hello kkrugel,

I had similar issues after dismantling a RAID array and wanting to repurpose the disks elsewhere. After much struggle I finally came across the dd command in linux. With this command you can basically (and easily) overwrite the ENTIRE drive with zeros (or random data). This worked for me since the RAID descriptors that was left behind on the drive is also cleared.

My suggestion is to download a user friendly version of linux such as Linux Mint (Mate or Cinnamon edition) and write the ISO (in your windows10) machine to a flashdrive with the Rufus tool. Simply boot up your machine from this flashdrive, with the target RAID drive plugged into a SATA port. Refrain from using external USB cases since some of them do not easily/correctly pass all the commands and procedures to the drive directly.

Once booted into Mint, open a command terminal and run the dd command for your drive. Details on this is readily available, but looks something like this: dd if=/dev/zero of=/dev/sdX bs=1M [#replace X with the target drive letter. Usually sda on a machine with only one drive!] To be on the safe side, I would unplug all the other SATA cables from your existing drives in case you get the drive name wrong. You can also use the fdisk -l command in the terminal to determine the correct drive name (sda or sdb and so on. Do not add a partition number after the drive name otherwise it will only wipe that specific partition and not the entire drive)

For large drives this procedure can take a LONG time. Be patient. On Linux Mint you can also pass the status=progress switch to the dd command by adding it afterwards i.e: dd if=/dev/zero of=/dev/sdX bs=1M status=progress. This will give you an indication as to how much data has been written.

Once the dd command has done its thing, you can create a partition table with a tool (in linux) such as gparted or gnome-disks or attempt it in windo$e again. (also, have the machine on a UPS in case of power failures, lest you have to begin again!)

The ease and versatility of this and other procedures convinced me to switch over to linux entirely.

Good Luck!