3TB WD red showing up as only 800gb drive after NAS os upgrade

I had two WD red 3TB drives in a synology NAS configured as raid. Everything was perfect, until -. I updated the synology OS (DSM) and it seems the drives somehow got corrupted.

  1. I have backups, so I’m not interested in restoring the data on the hdd’s.
  2. both hdd’s seem to be corrrupted (explained below).
  3. I removed one hdd and ran several tests. All test show perfect hdd.
  4. SMART - perfect.
  5. badblocks (linux) - non destructive r/w the whole drive - 0 errors
  6. WD Life Guard - PASS (the only test I didn’t run was the long one).

I’m pretty sure the drive is fine, but it is only showing up as about 800gb. How can I reset this back to 3TB?

I’ve tried:

  1. gparted (linux) - reports 1 partition 800gb
  2. windows disk management - reports 1 partition 800gb
  3. gnome-disk-utility (linux) - reports 1 partition 800gb


Have you tried writing zeroes to the drive using WD DLG?

Data Lifeguard Diagnostic for Windows

Maybe the NAS has to be setup again and the drives reformatted using the NAS?
Had to do that with my cheap Omninas KD20.

I put one of the drives back in the NAS and got it working again. It show’s as 3TB. The other drive is the drive in question. I tried reformating it, thinking it might restore it to 3TB. I’ll try putting it back in and see what happens.

But if the NAS can do it, there should be a way to do it outside of the NAS - shouldn’t there?


Well I guess it all depends how the NAS formats the drive for it’s specific system. I’m pretty sure if I took a drive from my crappy KD20 and put it in your NAS it wouldn’t read it.