Importing files from sd card after first import


I’m testing a my passport I bought today. I took a couple of photos, took the sd card out of the camera and put it in the MPW, as I had set it to copy on insert four files copied over, two raw two jpg.

Then I put the sd card back in the camera and repeated the excercise. However, the new files will not copy over, automatically or manually through the my cloud app.

Additionally it says the last import was in 1970.

Any ideas,

Hi there,

Have you made sure the unit is on the latest firmware? Also i would like to know if you are getting the error when you try to move the files.


Thanks for the reply, yes my drive was shipped with the latest firmware. Moving the files doesn’t help.

Today I tried whilst the drive was wirelessly connected to the computer and this error popped up (both move and copy).

Internal server error. Retry your last operation. If the error persists, contact WD Support for assistance. (310021)

Weird as it worked the first time.

Any ideas what to do, is this likely to be anything to do with the drive thinking that the last import was in 1970?

An update:

I reset the drive to factory defaults to see if that would help.

This deleted a load of files from the drive. Not only mine (as expected) but all the files and folders that were on there when I first booted the drive, I assumed these were sample files. I’m not fussed I happy they are gone.

I inserted the card and it successfully copied again. Took it out snapped a couple of shots and it wouldn’t copy these images, I got the same error as above.

So I tested a different (brand new) card got the error the first time I inserted it but managed to get files copied. Tested it in the same way, no problems.

This proved my first card was the problem. I formatted it in the camera and now everything seems to be working correctly.

Thanks for your help earlier.

Edit: the last successful import now correctly displays today’s date.