How to play Dual Audio


#1

Dear Folks ,

I have downloaded a mkv with dual audio track. I am not able to find any option for selecting audio language track on Elements Play. Any one can help ?


#2

It should be as simple as just playing the file, and while playing, hit the OPTION button, then select the AUDIO icon, and hit ENTER to select the next track.


#3

Thanks man … It worked …Cheers


#4

i tryed that and all i get when i click audio icon ac3 dts  ac3 sound but the russian language click button there nothing happen well goes slient then click back ac3 sound but not english when i play the movie on vlc player it gives me 2 options  but doesnt work on wd mulitimedia drive any idea


#5

The box doesn’t support DTS, so that’s why you won’t hear it.


#6

so if i download movie with 2 different languages i can only hear forgien not english language


#7

Who knows.   All I can tell you is that the EP doesn’t do DTS.  So if the language you want to hear is DTS, then no, you aren’t going to hear it.


#8

is there anything i can do like add a file or something or do u think it could be added as a firmware if possible thanking you,i found this siye to download full blu-ray 1080p and quailty excellent but cant change language is this elements mulitimedia drive old stock like is there newer one that changes language i only bought this 2 month ago


#9

Well, aside from buying the movie, your choices appear to be:

  • re-mux the file with MKVMerge, and only include the audio track you want, leaving the unwanted language(s) out
  • steal a different version that is English AC3

#10

RoofingGuy appreceate info what is re-mux mean what do i do is it record movie with another program minus sound then record the sound in english and merg togethr as movie thanks mate


#11

If you open the file with MKVMerge (pretty much regardless of what format it was in before), the program will give you a list of all the tracks in the file.

If you uncheck the audio track(s) you don’t want*, pick a new file name, and then click “Start Muxing”, it will create a new .mkv file that only contains which tracks still had checkmarks.

MKV merge is part of the MKVToolNix package.

*depending on which version of MKVMerge you’re using, you might/will also have to click each track you’re keeping and select the “Extra Options” tab and select “Compression – NONE”

(“Mux” is short for “multiplex”, “re-mux” is short for “re-multiplex”… the video, audio, and subtitle streams are all multiplexed into one file.)

But none of that really helps if the track you want to keep is DTS… it’s more just a quick way to get rid of unwanted languages.

You can replace the DTS track with an AC3 track, using Popcorn MKV Audio Converter or eAC3to.

Popcorn Audio Converter is a fancy interface for re-encoding audio within .MKV files.  If your file is another format, you’d have to run MKVMerge first and make it a .mkv.

But it will turn your DTS 5.1 track into an AC3 5.1 track and put the .mkv file back together with the new audio for you.


#12

hi roofinguy got the mkvmerge gui did what u said unclicked the russian language and when played back on vlc media player play english straight away when i put onto my wd multimedia drive it didnt play seen the mkv file but screen blank when pressed play and when i checked audio setting in vlc the russian language was gone but no video from wd elements play tryed old file played in russian  any idea i tryin to understand and learn how to fix this problem  the popcorn one is giving me error sayin it not mkv file and it is anymore help be great thanks mate