Wd elements play cannot play sounds for Blu-ray.DTS.x264.mkv

Hi Guys,

Does anyone know how to fix this problem: there is no audio for the “Blu-ray.DTS.x264 .mkv” movies when I use my elements play to watch this kind of movie. (no sound but have picture )

It seems like the elements play does not have audio spport for this kinds of MKV files. 

It works perfect when I play the MKV movie in the “ACC” audio formart. 

Is there any new fireware of software can be use to fix this problem (my current fireware is 1.00.10)


The Elements Play Gen1 does not support DTS audio.

Hey there

When you write Gen1, what does that mean?

I have just tried to play an .MKV file with my WD Elements Play Multimedia Drive.

The file only had DTS, and there was no sound.

So i tried out another file, which had DTS and AC3, and when I chose AC3 there was sound.

My question is what does Gen1 means and does my box support DTS audio?

Can you help me with that?

There are now two generations of WD Elements Play.

Only the Gen2 is licensed for DTS.