How to fix My Cloud Mirror disk "Bad" status

I’m not being able to use both original drives (WD Red 2TB) on My Cloud Mirror. Can someone help me to do so?

Long story short, I needed to backup files from a 4TB internal HDD and restore this backup to a new drive (both drives are internal to a desktop). The backup time would be huge if I would do the backup to My Cloud Mirror thru Ethernet. So I thought: what if I remove the HDDs from the enclosure and connect them directly thru SATA cables? It would take so much less time… And then I did it. But of course, I had to format the drives (and I did not create an image. Bad idea).

As a result of my journey, I sucessfully did the backup and replaced the intrenal drive. But when I tried to put the original WD 2TB drives back to the enclosure, I was not able to do so. I thought that putting the drives back to the enclosure would be the same as replacing both original drives for new larger ones, that is, the system should be able to format/create its needed file structure from scratch. But it seems not to be the case…

ps: I was able to format both original drives as EXT4. Both are fine and working well when connected to the desktop. The problem is just when I try to put it back to the My Cloud Mirror enclosure.

Below are screenshots of the messages i’m getting:

When I go to Settings->Utilities->Disk Test->Quick Test (I did not do a Full Test), all seems fine:

Self%20test%20results

So, I went to Storage->RAID->Set up RAID Mode. It leads to the self test before creating the RAID, that throws a disk status “Bad” and prevent me from moving on:

Just to be thorough, I’ve checked the system log and it has only the following message for both drives: “The drive x (x=1 or x=2, depending on which drive is being tested) self-checked failed. Contact WD Support.”

After all of that, I’m wondering why I get a “Passed” for both drives on Self Test Results and a “Bad” status for the same drives when I try to Set up the RAID? Anybody can help me to put My Cloud Mirror working again?

ps: I searched this forum extensively before creating this thread. Some threads looked promising to help with my issue, but none of them have worket out. The most simple and promising was this, posted by Danny: https://community.wd.com/t/my-cloud-mirror-replacing-drives-with-larger-drives/143535/7.

If someone can help, it would be much appreciated. Thanks!

The issue is that the drives don’t t have just a single EXT4 partition. It has at least a half-dozen different partitions.

The “Passed” on the Self-test is likely just saying that the RAID status is good (no surprise there…) but the “Self Test” may be looking at the partitions and data checks.

Interestingly, you have enough “smarts” left on the NAS that the OS is still working. When you re-formatted, did you clear ALL the partitions, or just the Data partition?

If you deleted all the partitions, my suggestion would be to do that again – delete all the partitions again, but don’t add any.

Then add only a single drive (drive 1) back into the enclosure. See if you can resuscitate that drive and get the RAID set up. It might only let you set it to JBOD – but just see what you can do.

The WD might re-create the partitions then.

Thanks for your help Tony! Unfortunatelly, your sugestion didnt work out. :confused:

Since my original post, I’ve tried other ways to solve the issue. The one that got closest was downloading an image of the original file system and writing it to my drives. It did pass on self test once, but I had choosed the wrong RAID configuration. So, when I went back to change it, the self test was a no go again.

I’ve tried two times to rewrite the image to the HDDs, but no success there. So, I’m calling for the day… I’m exausted! All I did today was try to fix this… :persevere:

Thanks again for the try!

So… I’ve tried again this morning and all stays the same… Here are all the things that I’ve tried:

  1. NO SUCCESS - Formatted the HDDs as EXT4 (just one partition) and tried to set up the RAID.
  2. NO SUCCESS - Deleted all the partitions from the HDDs (both with all unalocated space) and tried to set up the RAID.
  3. NO SUCCESS - Tried to do what TonyPh12345 sugested (delete all partitions and try to set up as JBOD, with only one HDD plugged) , but it didn’t work out for me either.
  4. NO SUCCESS - Rebuilt the HDDs with an image provided in another post and try to rebuild the RAID. All te partitions are created, as the images below, but HDDs still fail the self test (sometimes one of the two pass, but the other fails).

And,

I’m out of options. Does anybody have any sugestion? Could it be a firmware/bricked system issue, despite the fact that I can access the dashboard normally?

Thanks guys.