MyCloud Mirror Gen 2 - RAID Healthy, Drive 1 Bad - My Fix

Posting as I didn’t find this exact same symptom combination herein, though several posts gave me hope that the “alert” algorithm was the real problem. If you encounter this same combination, something to try.

MyCloud Mirror 2 Bay, Gen 2, 4TB, RAID 1, circa Oct, 2017

First issue I’ve had with this unit in just short of 6 years.

Drive 1 LED showed solid red. Dashboard indicated RAID was Healthy, Raid 1 was Good, and Drive 1 was Bad. Seemed odd that Raid could be Healthy/Good with a Bad Drive. S.M.A.R.T results for both drives were identical. Quick Test on both drives came back Good.

Rebooted MyCloud from dashboard and all issues resolved. Possible(?) that running the Quick Test reset some internal register.

'Twas my lucky day. Hope it holds but I still obtained a new (spare) drive as insurance.

Hi @WdMc.48,

Have you opened a Support Case? If not opened, for more information, please contact the WD Technical Support team for the best assistance and troubleshooting:

Yes, Incident: 230908-000172
The response I received was prompt but I had continued to search the WD Community in the meantime and got enough clues that I tried something on my own. That actually resolved the issue with less effort than the response suggested. The response was as follows:

I would suggest you to please turn off the device and remove the drive one by one, then insert them back in the same bay you removed from (Left drive on the Left side and Right drive on the right side.) and then check if issue get resolved or not.

if issue still persist you can perform drive test using the link below and share screenshot of test result with us

My Cloud OS 5: Perform a Quick, Full, or System Test

This first step is more involved than what actually worked for me. Frankly I was surprised that running a drive test wasn’t the first step suggested.

This fixed my issue. The same condition recently returned and my “solution” worked again. I should add that although I’ve alerts ON, I received nothing. I just happened to notice the drive 1 light was red. So I’m thinking this is actually a false positive for the drive.