How to assign a static IP address to My Cloud Home

Hi All,

My use case is as follows:

I have a system (in a vehicle collecting weather data running Windows 10) that does not have internet access, but it has a switch. We use custom software on this system that reads and writes to a network share but it looks for a specific static IP address.

I have used other NASes where you can log onto the NAS and configure a static IP and it would work perfectly. But I cannot seem to find how to do this with the My Cloud Home? I’ve done some Google searches and all of the examples show how to set the IP via the dashboard, but when I go to https://home.mycloud.com/cloud/file, there is no option to do it? I also cannot find any option to to this using the WD Discovery Software on Windows?

Any advice will be much appreciated!

The My Cloud Home does not support static IP addresses

I know it’s an old thread but I set a fixed IP for My Cloud Home NAS drive directly through my COX cable modem/router. I imagine any service provider hardware would be similar, once you know the default login info.

How did you do that ? like in steps cose My Cloud Home - cant be reach with its ip address it says to me this … if I type in the IP to my browser ( goole chrome)

{“key”:“notFound”,“message”:“Not Found”}

So could you explain in steps how to use static IP with My Cloud Home ?
or add connect to it for folders via VPN ?

Thanks,

Ivo

After the initial setup (via DHCP), I logged into my COX Cable modem/router, then went to connected devices, selected the My Cloud Home, (I’m using my laser printer as an example since I’m waiting for my Cloud drive to be replaced by WD under warranty, procedure is the same) I selected “Edit” and it allows you to select DHCP or Static IP. Just enter a IP address within the range of your ISP Modem/Router, reboot the device and your set. See the screen shot I’ll attempt to attach.

Thank You Greyrock,

However for me it’s still not works. :frowning:
I revserved the IP address via Router as you suggested but My CLoud Home still not available thru the IP .
Browser says - {“key”:“notFound”,“message”:“Not Found”}

So I think no gui for this in the new My cloud home device - I think it’s in the older versions but I bought this like 4 days ago andthey just ignored the GUI for that interface. ://

And like this - My CLoud home can’t be used as a NAS to connect and work together with a fix IP … :frowning:

it’s just a cloud storage… :confused:

Thank you and have a nice day,

Ivo