How long should a RAID 5 rebuild take?

Hi Guys,

I ran the commands, ( the re-add, the remove and the add) but I get this message:

mdadm: /dev/sdc2 is not a block device.

here’s an output if it helps…

cat /proc/mdstat

Personalities : [linear] [raid0] [raid1] [raid10] [raid6] [raid5] [raid4]

md1 : active raid5 sda2[0] sdd2[3] sdb2[1]

      8778211776 blocks super 1.0 level 5, 64k chunk, algorithm 2 [4/3] [UU_U]

      bitmap: 2/2 pages [64KB], 131072KB chunk

md0 : active raid1 sdd1[2] sdb1[1] sda1[0]

      2097088 blocks [4/3] [UUU_]

      bitmap: 16/16 pages [512KB], 8KB chunk

unused devices:

thanks for your help…

OK… it’s a new morning, and I tried the commands again…

this time I get the following message:

mdadm: cannot find /dev/sdc2: No such file or directory

This message appears no matter which of the three recommended commands I try.

thanks in advance for anyone’s help.


If you type “mdadm --detail /dev/md1” it will not show the sdc2 device?

What about if you type “mdadm --examine /dev/sdc2”?

Can you post the output?

Now that your backups are finished, You can try a few more things.  Can you physically remove drive 3 and re-insert it and re-try the commands?

Hi Mate,

I shut down the system and removed the disk, then turned it back on without the disk.

Then I shut it down again and inserted the disk and turned it back on again.

Same thing… no change.  I even tried remove faulty, remove failed remove detatched… no difference… sigh…

outputs below… TIA.

root@xxxxxx root # mdadm --detail /dev/md1


        Version : 01.00.03

  Creation Time : Sun Nov  3 04:19:38 2013

     Raid Level : raid5

     Array Size : 8778211776 (8371.56 GiB 8988.89 GB)

    Device Size : 5852141184

   Raid Devices : 4

  Total Devices : 3

Preferred Minor : 1

    Persistence : Superblock is persistent

  Intent Bitmap : Internal

    Update Time : Tue Aug 18 08:07:18 2015

          State : active, degraded

Active Devices : 3

Working Devices : 3

Failed Devices : 0

  Spare Devices : 0

         Layout : left-symmetric

     Chunk Size : 64K

           Name : 1

           UUID : 9d063278:a3167319:2146d3d9:3260d27a

         Events : 292643

    Number   Major   Minor   RaidDevice State

       0       8        2        0      active sync   /dev/sda2

       1       8       18        1      active sync   /dev/sdb2

       2       0        0        2      removed

       3       8       50        3      active sync   /dev/sdd2

root@xxxxxxx root # mdadm --examine /dev/sdc2

mdadm: cannot open /dev/sdc2: No such file or directory

OK, remove the disk and try to mount it on your Mac.

1 Like

Yeah… I thought of that, but I will have to get hold of an external case or cradle… 

Will see what I can come up with… 

If I can mount it, should I format it or something?


Well Hallelulia!

I shut down the EX4 and removed the drive…

I attached the drive to a USB cradle to my mac.

My mac said it couldn’t read the drive and proceded to take me into the disk utility where I bounced around for awhile before deciding to create a new partition on it… which I did… single partition using the whole 3TB.

Inserted it back into the EX4 (which has auto rebuild turned on by the way…) and powered it back up.

After it’s usual start up, the red LED came on and it said volume degraded… just like before.

ssh into the box and tried a few things and it looked just like it did before.  I couldn’t remove the drive from the array as it said it didn’t exist… sigh!

One last attempt before I put my foot through the **bleep** thing… mdadm --add /dev/md1 /dev/sdc2

It returned the message mdadm: added /dev/sdc2

I was so shocked I froze up…

Finally I did a cat /proc/mdstat and sure enough it was rebuilding… telling me it needed 42,000 + minutes but it was rebuilding.

The LCD on the front of the EX4 also said rebuilding volume and showed 9999 minutes… 


I’ll post back when it’s done, but @skiwi YOU ARE A LEGEND… Kudos kudos kudos… thank you so much for your patience and all your help.

Hopefully I can give back to the community too…

Thanks again from down under!

That’s great news. The rebuild shouldn’t take anywhere near that time. What is it saying now?

All done now mate.

Checked I could access all my data (which I can) and turned on the media service to let it rebuild the database.

That didn’t take too long and all is good.

Question… do I need to do anything to md0?  See below…  it looks like md0 is a RAID1 array and it still has sdc1 missing.

The dashboard reports all RAID volumes are active and healthy.  Should I just ignore it?

root@xxxxxxxx root # cat /proc/mdstat
Personalities : [linear] [raid0] [raid1] [raid10] [raid6] [raid5] [raid4]
md1 : active raid5 sdc2[4] sda2[0] sdd2[3] sdb2[1]
8778211776 blocks super 1.0 level 5, 64k chunk, algorithm 2 [4/4] [UUUU]
bitmap: 0/2 pages [0KB], 131072KB chunk

md0 : active raid1 sdd1[2] sdb1[1] sda1[0]
2097088 blocks [4/3] [UUU_]
bitmap: 12/16 pages [384KB], 8KB chunk

No, md0 is the system.  The md1 is the RAID 5.  Looks like you are good to go.  the GUI should say all is good.  To be sure, check the SMART status of each drive (from the GUI).

1 Like

Smart Status all good.

Thanks again for your help.