Hidden .wdmc directories created by mcserver and photodbmerger and the deletion of them

“SSH to the device”

I’d really love to. But nothing I try works.

I have Putty installed.

I follow the instructions, which are really simple: enter the host, click Open, response to prompts for username and password.

Except it never prompts me. It opens a black dialog with a cursor in the upper left, and sits there until it times out.

I’ve enabled SSH on the WDs (I have two EX2s).

What are the exact steps to enable SSH and successfully log in?

 I’ve enabled SSH on the WDs (I have two EX2s).

The instructions here are for the consumer MyCloud.

The EX2 is a different beast entirely, and has its own forum:


SSH instructions:


On the MyCloud, you need to access via port 22, i.e. :22. No idea what port it is on an EX.

SSH port will be the same on any device (unless pointed otherwise). On the EX2 what changes is the user name which is SSHD

On the EX2, I have enabled SSH, and entered a password. The UI confirms all is well.

In putty, there is a field to enter the hostname, which (I assume) is the  http://172.xx.xx.xx/ IP address of one of my EX2s.

The port defaults to 22.

The protocol defaults to SSH.

Under connection, there is a field to enter the logical name of the remote host. Not sure what to put there. I tried the same IP address and that didn’t work.

Under Data, there is a field to enter the auto-login username. Entering sshd there has no effect.

There are a bunch of fields under SSH, but instructions online for using putty to connect to SSH don’t indicate that any of those fields need to be messed with.

What am I doing wrong?

The HTTP, you just need to put on the ip address, so just the numbers.

Oh for crying out loud–simple! Thank you very much.

Hello, everybody!

I’ve stopped services wdmcserverd and wdphotodbmergerd on my device, but after rebooting they start again. I tried several times to edit my crontab with lines:

@reboot /etc/init.d/wdmcserverd stop

@reboot /etc/init.d/wdphotodbmergerd stop

and after rebooting these lines were deleted from my crontab file (so the processes started again)… Why it happens and how can I get rid of this removal?

slm-me wrote:

…how can I get rid of this removal?

You cannot…unless you’re willing to and have the skills to compile a custom firmware yourself. Be aware that you will void your warranty in doing so. In fact if you damage your system while using SSH you will lose your warranty too.

As to why this happens…simply because on device reboot the firmware is loaded from the flash - firmware that is read-only. When you make changes you are only making changes thatlast until the next reboot. And this is done primarily so that even if some user unwittingly mucks around in SSH and makes changes with bad repercussions, a reboot will undo most of those custom changes. It may not suit YOU but it is designed with the majority of customers in mind. Most customers are not going to muck around in SSH.

And btw, if you look in this sub-forum, you’ll find a thread or two describing solutions for the crontab problem…that solution will be persistent. It requires editing of a config file. Again, bear in mind that making these unsupported changes voids your warranty…so proceed at your own risk.

1 Like

Thank you for the answer!

Yesterday I quessed about the flash firmware that changes the settings. So you proved my guess.