HELP: WD Mybook not showing up in Explorer

I have a 4TB Mybook that I had never used before I plugged it in the other day. It doesn’t show up in File Explorer, so I can’t access it or format it. I opened disk management and this is what I get:


“Disk 2” is the Book. When I try to initialize the disk with either GPT or MBR it says “The request has failed due to a fatal device hardware error.”
In Control Panel it looks like this:
Attempting to update the drivers through there or disk management tells me that there are no available drivers or that the right drivers are installed, which clearly isn’t the case. I can’t find drivers for it on the internet though.
I have tried other USB ports, and other computers, neither of which have worked.
I have WD Drive Utilities and it looks like this:

Erasing the drive in there doesn’t work either: ![4|386x500]4 — ImgBB
The Quick and Complete drive test buttons don’t do anything at all.
Any help would be greatly appreciated.

As per the shared image, your drive is unknown and not initialized; whenever there is “disk unknown not initialized” issue occurs, your hard drive may show unallocated space in Disk Management, and the data on drive will be inaccessible or else there is another situation: there is no disk space shown in Disk Management (same as in your case).

However, you can try the below methods to resolve the issue:

Method 1. Use Disk Management to fix not initialized error on an external hard drive

  1. Connect the uninitialized external hard drive to your PC.
  2. Press Win + R keys, type: diskmgmt.msc and hit Enter.
  3. Find the uninitialized, unknown external hard drive with I/O device error > Right-click on it and select Initialize Disk.
  4. Then set the disk to initialize and set the disk as MBR or GPT.

After this, you may reboot your PC and keep all changes. Now, your external hard drive will be recognized and read by Windows again.

Method 2. Run CMD to repair I/O device error on not initialized external hard drive

This CMD command would erase all data on the uninitialized hard drive, which you can later restore after repairing the external hard drive not initialized, with the help of any data recovery or partition recovery software:

  1. Press Win+R > Type: diskpart and hit Enter.
  2. Type: list disk and hit Enter.
  3. Type: select disk F and hit Enter; (replace F with the drive letter of an uninitialized external hard drive) .
  4. Type: clean and hit Enter.
  5. Type: convert gpt or convert mbr and hit Enter.
  6. Type: create partition primary and hit Enter.
  7. Type: format quick fs=ntfs and hit Enter.
  8. Type: assign and hit Enter.
  9. Type: exit and hit Enter.

Hope it helps!

Thank for your reply, Jose.
The first solution did not help because now when I open disk management and right click the external hard drive, “Initialize Disk” is grayed out. The second solution didn’t help either since there is no letter for the drive.

Hi,

As your WD is not showing up and you are unable to format it in disk management then I would suggest you to choose the diskpart command to clean your disk and assign a drive letter to it.

Follow the below steps in order to clean the disk using diskpart command:

  1. Open Start.
  2. Search for Command Prompt, right-click the top result, and select the Run as administrator option.
  3. Type the following command to run DiskPart and press Enter:

diskpart

  1. Type the following command to list all the active drives and press Enter:

list disk

  1. Type the following command to select the drive that you want to clean and press Enter:

select disk DISK-NUMBER

  1. In the command, replace DISK-NUMBER with the drive number you want to repair as it appears in the “Disk” column. If you do not perform this step correctly, you could erase the wrong drive. Proceed with caution.

  2. Type the following command to wipe out the drive and press Enter:

clean

  1. Type the following command to confirm the drive still selected and press Enter:

lisk disk

Quick note: The output should include an asterisk (*) next to the selected drive.

  1. Type the following command to create a new partition and press Enter:

create partition primary

  1. Type the following command to select the new primary partition and press Enter:

select partition 1

  1. Type the following command to make the partition active and press Enter:

active

  1. Type the following command to format the partition using the NTFS file system, set a drive label, and press Enter:

format fs=FILE-SYSTEM label=DRIVE-LABEL quick

This example formats the drive using the NTFS file system and names the partition “Data”:

format fs=ntfs label=Data quick

  1. Type the following command to assign a letter and make the drive available in File Explorer and press Enter:

assign letter=DRIVE-LETTER

  1. In the command, change DRIVE-LETTER for the letter you want the drive to use, which is not assigned to another device.

This example assigns the “G” letter:

assign letter=g

  1. Type the following command to terminate DiskPart and press Enter:

exit

  1. Type the following command to close Command Prompt and press Enter:

exit

So, I got to step 9, and this happens:


I check Event Viewer and this is what I see: