Help needed unbricking WDMC Mirror Gen 1

Hi all,

Due to the imminent loss of support for WDMC Mirror gen 1, I decided to install @Fox_exe’s DSM 6 packages. Initially, DSM 6 (7393) worked great, then I tried upgrading to DSM 6 (8451).

I attempted the upgrade from a terminal (as root), wget upgrade-7xxx-to-8xxx.tar.xz, unpacking and executing When I came back from lunch, I noticed the session had disconnected, presumably from the last reboot command in Upon checking my router, I see that the WDMC Mirror did not attempt to reconnect, power LED flashing blue and disk LEDs flashing red. No change after power cycling either.

I could not find unbricking instructions targetting WDMC Mirror gen 1 on, but I did find this: As Linux is my primary OS, I followed the Alternative way section, copying and to /boot/uImage and /boot/uRamdisk respectively. Again no improvement, power and disk LEDs still flashing red / blue, and no IP address assigned by the router.

I would appreciate some hints to unbrick this NAS or links to guides I might’ve missed. I’m quite comfortable following instructions in a Linux terminal or soldering connectors for a JTAG cable. Thanks!

I’ve also tried the USB flash drive method (both USB ports 1 and 2), with and without HDDs installed. All not working. Can’t /dev/zero /dev/mtdblock1 because the NAS does not show up on the network.

Managed to restore functionality to the NAS (in the most roundabout way possible). Sharing some of my experiences for anyone that might find themselves in my situation.

After failing to recover the device by USB, I soldered wires to the UART pins and was able to get to U-boot. From there, I booted the factory uImage via TFTP. However, I was unable to login as admin user with a blank password. I suspect it was still checking against the last set password from WD WebUI, and that it was preserved somewhere in the onboard flash chip, despite having installed DSM 6 over the official firmware.

I got past that obstacle by booting the Debian uImage instead. Debian didn’t ask for a password. However, I soon realised dd-ing over /dev/mtdblock1 wasn’t going to work, due to bad blocks. flash_eraseall was not available, apt-get was not present and there wasn’t even dpkg to install a downloaded .deb.

I then went back to U-boot and looked more closely at the USB options. Seems like the USB device was being picked up, but not getting recognised as a storage device. Having already tried a couple of USB flash sticks a number of times with different firmwares, I wasn’t too optimistic, but I decided to use an ms-dos partition table instead of gpt. That’s how I finally got to the WD Recovery web interface. Uploading the latest stock firmware was pretty straightforward from there.

From the freshly installed WD WebUI, I was again unable to login as admin user with a blank password. However, the 40 second reset did the trick. That’s what made me wonder if perhaps WD stores the credentials in the onboard flash chip. Beyond that, Web UI will complain until drives are inserted into the bay(s), and if you wish to flash it immediately to a different firmware, you’ll first have to set up the drives, or the system won’t have anywhere to write the new firmware to.

That’s it! Hope this helps someone. Feel free to ask if you’re struggling with any of the steps. I’ll be happy to help however I can.