HELP! My Passport Studio drive completely stopped showing up on my Mac

I’ve had a Passport Studio 1TB for about 2 years and have used it with my late-2011 Mac Notebook (OS X Yosemite 10.10.2), connected via Firewire 400, and have never had any problems.

A couple days ago when I plugged the Passport into my Mac, and the Passport disk starts spinning, the light turns on and it at least seems to be trying to communicate with my Mac, but after about 20 seconds it gives up and quits.  The Passport will not show up in Finder for my Mac’s Disk Utility.  It’s like my Mac all of a sudden stopped recognizing the external drive completely.

I tried using a new Firewire in case it was a connection issue, but that did not work.  I haven’t had the opportunity to try plugging the Passport into another computer, so I don’t know if that would work or not.

I’ve been searching the internet for 2 days and I’ve seen dozens if not hundreds of people having the same or similar problem, especially with the latest Mavericks and Yosemite updates.  However, I haven’t found any solutions — just people all saying they’re having the same problem.

The only possible “fix” I have found was WD’s recommendation to install and update the WD SmartWare software.  I installed this app, but every time I click on the “Update Software” button, I get an error message that says “The WD update server is currently unavailable.”  I have tried this approximately 10 times over the past 48 hours, and I keep getting the error message saying the WD server is down (which in itself is beyond frustrating).

Can anyone please help me?  Pretty much my whole life is on this Passport and I can’t lose its data.

Thanks in advance.

Hello there and welcome to the WD community.

Have you tried using the unit on a different computer to make sure you can see the files inside? Just to make sure i recommend trying to do this if you are able to test on another computer.

1 Like

Thanks for the reply.

So I was able to finally test the Passport using (1.) a different port, (2.) a different connecting wire; USB vs Firewire, and (3.) a separate computer, and the bad news is that I experienced the exact same problem each time.

What happens is that I plug in the Passport Studio to my computer, the Passport disk starts spinning and I hear a few clicks, and this continues for about 20 seconds before the Passport gives up and powers-down completely.  It never gets recognized at all by the computer — not in Finder, not in Disk Utility, nowhere.

Is there any possible way that this is NOT a hardware problem with the Passport drive (maybe a Passport software issue??), or that it’s at least an easy fix?


What OS version does the separate computer have? 

1 Like

The other computer I tried it on was a PC — not a Mac.  And the result was the same.