HELP - Essential 1TB not recognized anywhere

Hi, I’ve a few months old 1TB Essential which worked perfect until 15 mins ago, when it fails to be recognized by anything. The power is good, the supply works, the light on the front lights up and after restart it gives it a few spins, but neither desktop nor laptop recognize it via USB. Could it be the cable dying on me ? 

Thanks in advance for any responses,

– Milos 


I am going through the same thing, it was plugged in and I was using it, then saw there was an upgrade which i followed directions and now my laptop doesn’t even recognize the drive. I tried it on my work computer and it is recognizing it, but not showing any files.  If anyone knows how to fix this PLEASE let me know. 

Thank you!

I have a 500gb Mybook and have exactly the same problem. Looking forward to replies…Alan


Same here, see:

I Think the drive just dies away… Unfortunately it seems that you neither can build it in as an internal drive nor can you use the case with another drive as an external… at least from what I have read in this forum. So back up as long as you can and go for new (not WD) drive space.

OK guys, here’s what it is.

The circuitry on PCB died.The HDD itself is good. So, I opened the encasing, removed the PCB, and plugged the HDD as a regular internal SATA HDD. The problem ? It is not recognized by any PC (or Mac), you have to initialize it and reformat it. After a bit of googling, we come to conclusion that WD hardware encrypts their own HDDs and that only with original PCBs you can retrieve the data. Or give it in to WD servicing and hope. The drive inside is Caviar Green btw.

Since it was not any super essential data on the drive, I opted to just reformat and use the HDD as internal. But, the smart conclusion here is that WD is piece of junk and that I will never use their products again in this capacity. Eff you, WD, and your “encryptions”. I hope y’all smart folks with such ideas that only you can unlock MY data die a slow & painful death.

The drive is hardware encrypted by that board. To use as an internal you’ll have to reformat and write with zeroes.