Help copying data from WD red drive

Last week, I updated my My Cloud Ex2 Ultra to the latest firmware, and my unit immediately became bricked. All 3 front lights now alternate between solid and flashing red, and the NAS is completely undiscoverable anywhere in my network. I’ve tried all the basic trouble-shooting tips…soft reset, hard reset, new power supply, new CAT-5 cables, power cycling my router, etc. etc. I am assuming the My Cloud is fried.

What I am more concerned about is recovery of the data on my HDDs. I thought this would be a fairly simple fix, but apparently not.

I pulled both (8tb) drives out of the Ex2 Ultra. My NAS was set up as Raid 1, so I only need to access one of the HDDs.

I put one of the HDDs into a third-party USB case and plugged into my desktop tower, but I can’t access the drive in Windows Explorer due to something called “GPT Protective Partition” that was apparently installed on the drive when it was first set up. Some googling has led me to believe that I won’t be able to view the HDD in Explorer, in any way, unless I re-format and re-partition the HDD.

What is the easiest way to access my data now? If I purchase a new My Cloud EX2 Ultra and configure the blank drives to Raid 1, could I “hot swap” one of my old drives in, or would I be prompted to format the drive? Can I backup the HDD into my other NAS (a Synology) through its integrated USB backup software? Should I just try a data recovery software?

Help or thoughts are greatly appreciated.

if you add your drives to the new my cloud the drives will be in raid roaming, you have to confirm this from the dashboard. You wont lose any of your data. I would suggest doing it this way because once your system is up you can then FULLY backup your stuff ie. external hard drive… good luck! Also I got a my cloud ex2 and ex2 ultra for sale. If you are interested, send me a pm. maybe i can loan one to you for a deposit? Whatever works for you. I been in your spot before, spent over 300 in recrovery software. it was terrible…

The drives would have a Linux file system.

Can you see your data in DMDE?

… or Linux Reader for Windows?

I don’t know if this will be of any help to you:

Make a ubuntu live image, download rufus and the any version of ubuntu 20, latest is preferred. Boot your pc into live mode (live is to test the os without making any changes to your pc, use rufus to burn the ubuntu image to your usb stick. Boot from that, use “Disks” to mount/access your drive.

Hey man, thanks I really appreciate. I was able to boot the HDD in “safe mode” by plugging into my Synology. From there, I ran a USB Mirror Copy into my synology. Still some clean-up to do with the files, but everything seems to have copied over.