Help! 2 TB My Book works but not works! Really strange

Hi people,

My moribund WD external disk is behaving strangely. Let me describe my diagnosis. Initially i think the problematic USB port of this laptop caused this situation and then after it cannot be detected by computer. For several days this windows 10 could detect the WD My book but not showing it in My Computer, in other words it was inaccessible but after hundred times trying to reconnect it came up strangely once and i could copy some files but not entire the disk (unfortunately my PC went to sleep after several hours). I tried to connect and reconnect the disk to the computer for days but no hope. You know these drives are god ■■■■ self encrypted and I knew i cant get my data back by just connecting it to SATA port but out of curiosity i just removed the enclosure and connected the disk to my computer and it detected without any problem.
The story doesn’t come to an end here, something is really funny. I have another 500 GB SATA disk and i just used this maybe broken WD 2 TB PCB on it and it worked like charm without any problem when I connected it to PC. OK.
It sounds strange.
My question is how is it possible? Why this WD MY Book controller board (the board that connects the drive to computer ) doesn’t detect healthy 2 TB disk and it detects that 500 GB SATA disk flawlessly. Alright, I just bought another external disk enclosure and I just put this 2 TB disk in it and it also worked.

In brief,

  1. WD My Book failed, most probably because of problematic USB port.
  2. It came up ONCE just randomly after the accident and worked for a while without any problem.
  3. SATA drive inside the box is Healthy and working (but encrypted).
  4. WD enclosure board works fine with another SATA disk.
  5. Here it comes up again (I mean 2 TB encrypted disk) and it works fine for hours.
    6.Everything is in worst situation now. When I connect the disk to computer (tested on several Computers different ports , usb 3, usb 2 ), it is like nothing is connected to computer.

Any idea why is it like this?
:confused:

Hi Marshal,

Maybe you should try contacting WD’s Technical Support about this.

To Contact WD for Technical Support