HDD Replacement (Single Drive)

Greetings , 

I need an expert here :smiley:

I have opened my cloud enclosure , removed the 2 TB HD and formatted it to use it somewhere else , and installed WD 500 GB Hard Disk in the enclosure instead.    

I know this will void the warranty , but warranty is not my concern here.

When I started my cloud with the new HD , it couldn’t be located in the network , and the indication LED was not green. It seems that the dash board software is installed on the original HD which was already formatted. 

My Question is : 

How can I install WE Dash Board on the new 500 GB HD ? Or how can I bring my cloud back to life :confounded:

You need create new GPT table and upload kernel, rootfs and BootConfig.

You can find all in my Google.drive folder:  https://drive.google.com/folderview?id=0B_6OlQ_H0PxVRXF4aFpYS2dzMEE&usp=drive_web

* “Replace HDD.txt” - Is what you need + backup files. (Instruction is Russian. But you can just run commands)

if need - i can translate.

1 Like

Thank you very much for your reply.  Actually , I used Google Translator to translate the file to English. I got a readable result :stuck_out_tongue:, and I will try to follow the translated instructions. I will let you know once I’m done.

Thanks again :smiley:


I have followed the instructions , and it worked !!!  :smiley:   :smiley:  :smiley:

The problem now is : 

When I access My Cloud using the browser , I got notified that a new firmware is available. When I tried to upgrade , I got the following error : 

  • Device does not have enough space for upgrade. (370002)

The current firmware version is V03.04.01-219  while the new one is WDMyCloud 04.00.00-607 .

I have noticed in the capacity section , it shows “0” KB Free !!!  The new installed HDD is 500 GB , not 2 TB , would that make a difference in the way the HDD is partitioned ?  

Thank you

To fix “0 GB Size” - Just do reset from web-gui (Not full reset!)

And - Run a pt-get update && apt-get upgrade for update all internal software (in particular OpenSSH - to fix “HeartBleed SSL issue”)

Great !  it’s working now :smiley:  My “My Cloud” is back :smileyvery-happy:

Thank you very very much for your help and prompt response. I really highly appreciate it :smiley:

please explain in deeply…

what OS i needed ???

what tools i needed ?

what do i first ?

{ I have 4 TB my cloud external Hard drive. It is almost already ready…THEN

  I took hdd from it and replace unformmated 500gb WD hard drive…

now my cloud display solid red LED light…

pls give me solution…

 This topic describe all that need to me, the same issue downgrading from a 2tb hdd to a 500gb one. I’m going to try later so I’ll keep you informed about the result…! I hope google translator from russian to italian will be reliable :wink: