Has this mycloud been hacked

When I log in to admin the nice html home page comes up but before I can interact my session times out.

Login timed out. Please login again.

The home page reports that the system is healthy and that my firmware is version 2.31.183. This is a worry because the latest firmware here is 2.31.174.

All my on board user data is still accessible as is the attached usb drive. A soft reset just deleted my admin password. I’m afraid a hard reset will delete my user logins and effectively brick the thing.

Try using a different browser.

1 Like

The latest firmware is 2.31.183.

Look here for the latest firmware.

Click on, tap or activate image to enlarge it.

1 Like

Thanks Tom. I tried chromium which is fast and I can actually get into submenues. Managed to check to see that my public shares were actually public. But the timeout is still way too fast to do anything else useful.

I did manage to check and find that that automatic firmware update is turned off. It therefore seems strange that I have the latest version. It updated on Tuesday 4th June 2019 at 10:00.28. I was at work then.

Thanks cat for the link to the 184 firmware. Maybe if WD were a little better at site maintenance I wouldn’t have followed the trail to the page (linked to above) that gave me the wrong information.

So I almost feel emboldened to try a hard (40s) reset. but remain unsure what to do. Maybe I will try and turn auto firmware updates on in the hope that that will eventually fix things.

So far so bad. Have done a hard reset and am using the fastest browser I can find. The login time-out is still stupidly short. I can’t manually update firmware because my admin session times out mid way thru the firmware file transfer from my computer.

Any suggestions?

Are you using a Mac by chance? If so WD suggests using Chrome or Firefox. And WD suggests using the IP address of the My Cloud rather than wdmycloud.local to deal with the time out issue that affects Safari.

My Cloud Dashboard Login Time Out Safari Browser

1 Like

No Macs here. Have tried both Firefox and Chrome over Windows 8.1 and Windows 7, Firefox on an Android tablet. Best results are with Chromium over Linux Mint. Generally the timeout occurs after about 5 second of inactivity. Hopeless.

Few more suggestions.

Is the local network time, the time on the computer or device and the time on the My Cloud Dashboard > Settings correct (all the same)?

Is the correct time zone selected within the My Cloud Dashboard > Settings?

Is NTP service enabled on the My Cloud Dashboard > Settings?

Is there security software that is used across all your local devices experiencing the time out issue?

Is there a browser add-on or browser extension that is being used across ll the devices that are exhibiting the time out issue?

I somehow managed to set the time zone and turn on NTP

It made no difference

No common security or browser addon software.

Thanks for the suggestions. Very good of you.

I’m going to mark this issue as solved.

Having previously carried out both soft and hard reset procedures with the button on the back I was wondering what else to try. Here is what fixed the problem. I don’t know if this is relevant but I unplugged my usb drive before starting this process… Starting at the main admin homepage I Selected:
Settings > Utilities > Device Maintenance > Reboot.

Upon my return I was put through the startup wizard. It didn’t perform quite as expected but there were no timeout problems with it. Back at the home page I soon realised that my timeout problem was gone. BUT My users and self created shares had all disappeared. Everything in the /Public folders was still there.

Being optimistic I created a new share with the same name as the old one and to my surprise all my files were still there.

Recreating the users was easy enough.

I hope someone finds some use for this information.