Has Anyone had a WN111 wirless adapter working with Live Hub?

I purchased the netgear WN111 as it was on the supported list of adapters for the live hub. I made sure I had the right version, and have the latest version firmware. However, the WN111 is not even recognised by the Live Hub.

I have tried the WN111 in a PC and it works fine. I even tried an old noname wireless g  usb adapter in the live hub and that worked first up! Trouble is it is way too slow, and is a bit far from my router to keep a good connection.

I am somewhat annoyed at buying something based on WD recommendation, and it is certainly not working for me. I am not even going to go on about the poor tech support I had getting to the point where they eventually (after a week of emails back and forth) advised me to return the live hub and get another one.

Anyway, just thought I would see if anyone else had tried the WN111 with any success?

So you have exactly this adaptor.

Netgear RangeMax Wireless-N USB Adapter WN111 Not Listed*

Note that this adaptor has no version or revision.

Yep. The support guy must have quoted the web site guide lines for this adapter about half a dozen times.

There is no version or revision number on the device or the box, just WN111.