Handling of letterboxed (not anamorphic) DVD rips

I have a hard drive full of rips of my personal DVD collection, stored in somewhat ‘original’ IFO/VOB format. The WD TV Live box plays such rips well, which is why I chose it over (eg) the Roku device.

 

However, a small number of ripped DVDs don’t play appropriately on my widescreen TV.  Most do. I’ve spent a whole day experimenting, and here’s what I’ve found.  Some of my older DVDs are ‘letterboxed’ - that is, they are stored as 4:3 images, with ‘bars’ at the top/bottom to give them the correct visual 16:9 aspect ratio.  These are NOT anamorphic disks (anamorphic 16:9 play fine).

 

When I put the original DVD in my DVD player, and play on my widescreen TV, by default, the image is ‘too wide’ - it fills the full width of the screen but is squashed vertically.  But my TV has a mode it calls ‘zoom’, which (not really consistent with it’s name) stretches only the vertical plane, to make the image fill the (16:9) screen and looks normal.  However, when I play a direct ‘rip’ of this DVD through WD TV Live, on the same TV, same settings, the image plays with both vertical and horizontal bars around the image.  I can achieve a reasonable image using the WD TV live by using a separate ‘zoom’ feature on my TV, which stretches both horizontal AND vertical dimensions.  So both the original DVD and a rip from it ultimately look OK on the TV, but I have to use different ‘stretch’ techiques in either case, which suggests the WD TV is not quite behaving like my DVD player.  Just wondering if anyone else has encountered this and if there is a better way to handle it.

IIRC there was an option under video where you can set Aspect ratio to normal. Does this make a difference for those DVDs?

1 Like

Aspect ratio should not be changed. It is DVDs with poor usage of the format, yielding an extremely low resolution. AFAIK there is no other solution than zooming at he TV. I’ve only encountered one DVD in this format, Titanic, which for this reason got dumped when I transferred my collection to HD

Cocovanna wrote:
Aspect ratio should not be changed. It is DVDs with poor usage of the format, yielding an extremely low resolution. AFAIK there is no other solution than zooming at he TV. I’ve only encountered one DVD in this format, Titanic, which for this reason got dumped when I transferred my collection to HD

The American President was done the same way… worst transfer I’ve ever seen.

Techflaws wrote:

IIRC there was an option under video where you can set Aspect ratio to normal. Does this make a difference for those DVDs?

This in fact proved to be useful! I had experimented with this earlier but ruled it out, but once I got more detailed in my testing and note-taking, I can now say that, for playing ‘letterboxed’ movies without borders on a modern wide-screen (16:9) TV, and without any visual ‘stretch’:

  1. DVD player -> TV (zoom setting for verticle stretch)

  2. WDTV (wide AR setting) -> TV (wide setting) + 2x Zoom on TV (expands image in both dimensions)

  3. WDTV (standard AR setting) -> TV (zoom setting for vertical stretch)

#2 is what I was using, but #3 works also.

Note that ‘zoom’ as referenced above may be some proprietary feature of my (older) Vizio LCD TV - it stretches the image vertically but not horizontally, and was presumably implemented for this purpose.

The benefit of #2 is that I don’t have to change the setting on the WDTV, which loses my place in the folder navigation tree; the drawback is that my tv superimposes a ‘x2’ indicator on the screen to remind me it is zoomed.

The benefit of #3 is that the TV does not superimpose any indicator in this mode.

This only applies to a small number of movies in my collection, but it’s enough to be a pain. I was an ‘early adopter’ of DVDs, buying entire collections of my favorite movies when they first came out - I have an early ‘woody allen’ collection, a  ‘stanley kubrick’ collection, etc, and these are some of the ones that are letterboxed.  I actually have two copies of some of my favorite movies - Cuckoo’s Nest and Thelma and Louise, for example. The first copy I bought was letterboxed, the later copy was anamorphic. I assume it’s pretty hard to come across a letterboxed DVD these days …

Now I’m going to see how I can play them on my HDMI monitor …

Steerpike wrote:


 

Now I’m going to see how I can play them on my HDMI monitor …

 

 Hmm … all my typing disappeared …

Bottom line - doesn’t work well on my samsung 27" monitor using HDMI input - it has no zoom/stretch features at all. I’ll look at some other monitors in my collection.

Update - just tried it on my Vizio 26" monitor, HDMI input … same limitations. Darn!

@Steerpike

 

   which suggests the WD TV is not quite behaving like my DVD player.

It’s not the WDTV that is acting up – it is the file you are feeding it.  Tell ya why. . . .

I have a few older DVDs that are Letterbox – they were never “expanded” from the old SD letterbox format for today’s widescreen TV use as many re-done DVDs (and blu-rays) have been.  So, when I made an ISO from them for playing on the WDTV, I still had a letterbox format that was pretty small.  So, the DVD and the ISO from it look the same.  (BTW, my Panasonic TV manual says to use the TV’s zoom control for playing old letterbox movies; not ideal because the picture is cut off a little vertically and horizontally, but it’s the best solution there is.)

Now, you are not feeding an ISO file of the DVD to the WDTV, you are feeding it an IFO/VOB.  This is likely causing your issues.  Make an ISO of the problematic DVD, and when you play the ISO, what your WDTV shows will also be the same as what your DVD player will show.  If you made the movies as MKV files, I do not know if that could improve things since I have not done so.

In addition, I converted these two movies to m4v files with Handbrake’s default setting for use on the iPad.  Handbrake processing eliminates all the “black area” i.e. the letterbox black bordering, so when seen on the iPad, the movies I made are in widescreen, with just the narrow top and bottom black borders like any other widescreen movie of today.

I am not a Handbrake expert – I use it for making iPad video files, and that’s all.  It might be possible for Handbrake to make an MKV file from the DVD or ISO so that the letterboxing is eliminated just as it was for my m4v movies.

Handbrake experts  – jump in here.

1 Like

mike27oct wrote:

@Steerpike

 

   which suggests the WD TV is not quite behaving like my DVD player.

 

It’s not the WDTV that is acting up – it is the file you are feeding it.  Tell ya why. . . .

 

I have a few older DVDs that are Letterbox – they were never “expanded” from the old SD letterbox format for today’s widescreen TV use as many re-done DVDs (and blu-rays) have been.  So, when I made an ISO from them for playing on the WDTV, I still had a letterbox format that was pretty small.  So, the DVD and the ISO from it look the same.  (BTW, my Panasonic TV manual says to use the TV’s zoom control for playing old letterbox movies; not ideal because the picture is cut off a little vertically and horizontally, but it’s the best solution there is.)

 

Now, you are not feeding an ISO file of the DVD to the WDTV, you are feeding it an IFO/VOB.  This is likely causing your issues.  Make an ISO of the problematic DVD, and when you play the ISO, what your WDTV shows will also be the same as what your DVD player will show.  If you made the movies as MKV files, I do not know if that could improve things since I have not done so.

 

In addition, I converted these two movies to m4v files with Handbrake’s default setting for use on the iPad.  Handbrake processing eliminates all the “black area” i.e. the letterbox black bordering, so when seen on the iPad, the movies I made are in widescreen, with just the narrow top and bottom black borders like any other widescreen movie of today.

 

I am not a Handbrake expert – I use it for making iPad video files, and that’s all.  It might be possible for Handbrake to make an MKV file from the DVD or ISO so that the letterboxing is eliminated just as it was for my m4v movies.

 

Handbrake experts  – jump in here.

I’m about to buy handbrake for other purposes, so I can certainly give this a try. My friend swears by it and I can imagine it would be an easy process to modify the data to play in a better manner.  In the old days, I used work hard on these projects and had ‘avisynth’ scripts and used “TMPGEnc” to do all kinds of manipulations on the DVDs … but those days are gone!

But regarding your comment about creating an ISO vs. feeding it IFO/VOBs, if the IFO/VOBs are straight ‘DVD-Decrypter’ ‘rips’ of the DVD, with no manipulations, shouldn’t the IFO/VOB behave the same?  Regardless - and excuse this dumb question since I’ve just never gone down this path before - I tried creating an ISO using ImgBurn, and it warned me that since the DVD was encrypted, it did not recommend creating an ISO.  How would you suggest I create an ISO for use in the manner you suggest above? Ignore ImgBurn’s warning?

Edit To Add: I guess I could use DVD Decrypter in ISO mode … I’ll try that.

Steerpike wrote:



I’m about to buy handbrake> Handbrake is *Free* and Open Source (be very careful if where you’re getting it is asking for money)

1 Like

sssasdJoeySmyth wrote:


Steerpike wrote:



I’m about to buy handbrake> Handbrake is *Free* and Open Source (be very careful if where you’re getting it is asking for money)

Thanks for that info - I was actually unaware of it’s pricing strategy (haven’t visited the site yet).

Regarding using an ISO vs. ripped IFO/VOBs - I created an ISO using DVD Decrypter and … YOU WERE RIGHT! (this is to the other poster Mike27Oct  - is it possible to multi-quote in this forum?).  Can you explain why - it makes little sense to me, given that the IFO/VOB rip creates a very similar file structure on the hard drive as existed on the disk?

Anyway - however it works, now I know it works and that’s a help.

Next - download Handbrake and see if I can get it to testructure the media to be more ‘monitor friendly’.

As said, Handbrake is totally free, so you get it from the source website:  http://handbrake.fr/

Most people do not create IFO/VOBs much these days.  They either create MKV if they want just the movie file, and they create ISO files if they want a duplicate of the DVD  (menus and all).  I like to make ISO files and then make other types from them if I need to.

Decrypter is kind of an old program… I use one that costs $$ called AnyDVD HD, but many others use a free one called DVDFab, I believe.  Both decrypt a DVD, so the video files can be processed/extracted to create ISOs, MKVs and mp4/m4v files.  Check it out, and retire DVD Decrypter.

I wondered earlier if Handbrake could take one of my letterbox DVDs and create a non-letterbox MKV file by removing the letterboxing black space.  IT DID!  It just finished and movie looks good. 

This is how I set up Handbrake for the job of making an MKV file:

On right menu do not select from the Devices/Presets.  Select from Regular/High Profile

Select your file to process

Click to choose container:  MKV file

In middle of main screen notice that Cropping is set to Automatic – (leave it there because that is what crops out all but the movie (and letterbox border is removed)

You are ready to make your MKV from an ISO file.  Click Start, above

BTW, I often make MKVs using another program that is quicker and does a great job called ByteCopy.  But it just extracts the movie file, unlike Handbrake that can extract AND process (to remove letter boxing).  So, until your message I had not thought to use Handbrake this way for letterbox stuff, so thanks for making me think about this problem!

Steerpike wrote:


is it possible to multi-quote in this forum?

Nope, Lithium **bleep**.

Steerpike wrote:
Can you explain why - it makes little sense to me, given that the IFO/VOB rip creates a very similar file structure on the hard drive as existed on the disk?.

With VOBs being in an VIDEO_TS-folder, the WDTV should treat them the same as ISOs. Apparently it does not so I would put the player at fault here. You could write a batch for ImgBurn and convert all your folders to ISOs (in case you don’t want to invest the time to learn and encode with Handbrake).

Techflaws wrote:

    • *> * * *
      Steerpike wrote:
      Can you explain why - it makes little sense to me, given that the IFO/VOB rip creates a very similar file structure on the hard drive as existed on the disk?.

With VOBs being in an VIDEO_TS-folder, the WDTV should treat them the same as ISOs. Apparently it does not so I would put the player at fault here. You could write a batch for ImgBurn and convert all your folders to ISOs (in case you don’t want to invest the time to learn and encode with Handbrake).

I was wrong; the ISO I created was treated exactly the same as the ISO/VOB file set in the VIDEO_TS folder; I had overlooked the fact that I had modified the setting on the WD TV live in a previous test.  So I just confirmed - WDTV live plays an ISO the same as it plays an IFO/VOB set.   Oh well, I wish it weren’t so but logic told me it should be that way!

mike27oct wrote:

 

I wondered earlier if Handbrake could take one of my letterbox DVDs and create a non-letterbox MKV file by removing the letterboxing black space.  IT DID!  It just finished and movie looks good. 

 

This is how I set up Handbrake for the job of making an MKV file:

 

On right menu do not select from the Devices/Presets.  Select from Regular/High Profile

Select your file to process

Click to choose container:  MKV file

In middle of main screen notice that Cropping is set to Automatic – (leave it there because that is what crops out all but the movie (and letterbox border is removed)

You are ready to make your MKV from an ISO file.  Click Start, above

 

BTW, I often make MKVs using another program that is quicker and does a great job called ByteCopy.  But it just extracts the movie file, unlike Handbrake that can extract AND process (to remove letter boxing).  So, until your message I had not thought to use Handbrake this way for letterbox stuff, so thanks for making me think about this problem!

 

I did as you describe above, and a preview of the product using VLC looked great on my PC (all material present), but when I actually copied the mkv over to WDTV, and played through my TV, it was way off - missing material on all sides, as if ‘zoomed’ but with no zoom applied.  Did you test the file on your actual WDTV and TV setup?   I spent the last several hours messing with this, and I think I’m ‘almost’ there, but not quite ready to declare victory. Here’s what I did to get ‘close’:

Width: 720 Height 480  

Anamorphic: Custom.

Modulus: 16

Display width: 854

PAR width: 32
PAR height: 27

Cropping: Custom

(set top and bottom each to 38; no left/right cropping).

I chose these values, basically, by creating an ISO of a perfect anamorphic 16:9 DVD, and looking at the settings handbrake suggested by default.  I came up with the top/bottom ‘crop’ values myself, and need to further tweak them.

Will work on this more tomorrow…

Width: 720 Height 480  

Anamorphic: Custom.

Modulus: 16

Display width: 854

PAR width: 32
PAR height: 27

Cropping: Custom

(set top and bottom each to 38; no left/right cropping).

If you kept the Display width @ 720 (and top/bottom crop 40 … resulting in 400 Height) it would have been all good

(I never trust Automatic Settings)

Something i do … Play the video in VLC and take a “snapshot”  (it’s under Video Options)

Take the snapshot in a graphics editor eg. GIMP or Photoshop

Use a “Select” tool and cut out only the video image (ignoring the Black Borders)

Paste this as a New Image and then have a look a the Picture Dimensions… and use them as a guide for Dimensions / Cropping settings for the Video File.

eg.  Here’s a 720x480 4:3 Aspect Matted Widescreen screenshot from VLC

Cut out the Black Borders in GIMP / Photoshop and you now have the settings to use in Handbrake

720x400 16:9 Widescreen Aspect Ratio  (eg. in Handbrake keep 720 the Width, Top & Bottom Crop=40)

When you play this *new* 720x400 file on your WDTV (assuming you have the settings set to “Widescreen” and your TV set to 16:9 … you will get the movie displaying in proper aspect 16:9 … there maybe small Black Borders introduced at the Top and Bottom … (720x400 scaled to 720p = 1280x711  … All depends if you have “Overscan” on your TV whether you see the small black borders or not ) however, the picture should not be Stretched or Distorted at all.

Can you please elaborate. I just redid my test based on (my interpretation of) your comments. The result was just as good as my test - both are good, both have very narrow remaining bars at the top/bottom (and none at the sides), not a problem - could tweak those away if needed.  So let me see if my interpretation was correct.

I said:

Width: 720 Height 480

Anamorphic: Custom.

Modulus: 16

Display width: 854

PAR width: 32
PAR height: 27

Cropping: Custom

(set top and bottom each to 38; no left/right cropping).

You said:

If you kept the Display width @ 720 (and top/bottom crop 40 … resulting in 400 Height) it would have been all good

(I never trust Automatic Settings)

 Did you agree with ALL my other settings - anamorphic: Custom, PAR values, etc? I ask because, once you set ‘custom’ on Anamorphic, several additional settings open up, including height, Display width, etc. 

The reason I came up with a Display width of 854 was that 854 is my understanding of how a 720x480 standard DVD image is displayed when DAR (Display Aspect Ratio) is set to 16:9 (vs 640 for a DAR of 4:3).   854x480 = 16x9. Now, with your settings, 720x400 ~= 16x9 also; so we both have correctly scaled images.   I was concerned that having a 400 pixel height would be a problem, since true DVD is always 480, and that’s why I set 480 as the height still; but cropping from 480 to 400, then scaling back up, is extra processing and if it’s ok to push out a 400 pixel image, and WDTV scales it anyway, then no problem.  But then I’m thinking, if we are keeping the ‘display’ width at 720, and the input is already 720, is there any need for ‘anamorphic’ settings at all …? I obviously need to do a refresher on anamorphic :). Here’s my latest settings:

HandbrakeLetterboxDVD-to-16-9-test5-cropped.jpg

This has been an interesting exercise for us it appears.  So, while you guys have been trying things out with Handbrake, I have,too, and after a few attempts, I have a successful mkv from the letterbox DVD.  My first attempt looked good on PC, but when moved over to play via the WDTV, it was bad  – too much jerky-ness and out of sync with audio issues.  Same with a second try.  Third time was a charm.

Past experice making files for use on the iPad alerted me to the importance of the framerate setting.  So, I went back and read about it in Handbrake Help.  Here is the URL of the link that opens from within Handbrake when Help is clicked (I have it bookmarked in my browser):   https://trac.handbrake.fr/wiki/HandBrakeGuide

Look down TOC and find the discussion about Frame Rate.  This comment in there was particularly helpful for making this mkv:  "But if you find that playback is jerky, you might want to experiment by specifying a particular framerate instead of using ‘Same as source.’  " 

OK, and since I had jerky video, I read more and thought about it.  What I needed to do was find the framerate of the original movie (ISO file), and since MediaInfo can’t detect it from an ISO file, I played it with VLC, and under theTool tab it has a Codec info tab, and there was the framerate I needed.

So, I made minimal tweaks to Handbrake, and what tweaks I made were on these two tabs  – on tab for Picture and on tab for Video.  Screen shots and notes are below:

BTW, the movie and audio are in sync, the video has no jerky-ness and the focus seems better, too.  Being that the small picture withn the letterbox video has to be enlarged to now fill the screen, it necessarily looses some clarity.

As before, I used the main setting of Regular/HighProfile.

Picture tab:   I left Cropping on Automatic to remove the letterbox black frame. That’s all; I made no changes here.

Video tab:  I selected the correct framerate on this tab and changed from Peak Framerate (the default)  to Constant Frame rate.  I have no idea what “Peak” Framerate means (guide does not explain it) , so I opted out.  Only made these two changes here.

So additional info to add to my last comments.  The mkv came our so well, that I did a second letterbox DVD, and I made some additional tweaks:  I selected Peak Framerate which didn’t hurt, and may even help, so I will stick to that for any other letterbox movies I have.  (BTW, I have quite a few letterbox Laser Discs that I have recorded to DVD, and wonder if this process would be good for them, too, to fill the widescreen.  I’ll have to see.)

The other change I made was in the Audio tab.  I noticed the audio of both the ISO files were 192 kbps (although the Handbrake default was set for less at 160 kbps) so I cranked up the bit rate to what the DVD/ISO is; to 192.

Overall, I am happy with my results of this exercise.  What’s kind of ironic about this for me is, I really didn’t need to do all this, because only a few months ago I purchased both these movies on blu-ray.  Now, there is a good picture!  I even had to buy foreign, all-region blu-rays made in Denmark (with original soundtrack), because the two movies have never been released on blu-ray in the US!  The blu-rays are stunning, too.  They are two of Woody Allen’s best movies.  (“Bullets Over Broadway” and “Everyone Says I Love You”.)  The guy’s a movie-making genius, but he just doesn’t get any respect from American movie goers except in a few rare cases.  The critics and the Europeans love him, though.  Me, too, and I have seen all but his few really bad movies.  One of my all time favorites is his “Sweet and Lowdown”, but it has not been released on blu-ray anywhere on Planet Earth.  I’m still hoping it will be someday.

Steerpike wrote:But then I’m thinking, if we are keeping the ‘display’ width at 720, and the input is already 720, is there any need for ‘anamorphic’ settings at all …?> Nope,  i set Anamorphic to “None” because i’m using exact video dimensions.> To confirm my perference not to use “Automatic Settings” see above:  Input: 720x480  Display Size output: 641x346> I know in video encoding there is always some loss in quality … but to downscale from the original dimensions is something i would not want.