[GUIDE] How To Unbrick your 2TB/3TB/4TB My Cloud


#21
  • We’re looking for the start sector of the last partition (4).  I would think it would be the same on 3TB and 4TB, but I can only speak for the 4TB, which is 9428992.
    rm 4
    mkpart primary
    File system type?   [ext2]?
    ext4
    Start?
    9428992s
    Warning: You requested a partition from 9428992s to 7814037167s (sectors 9428992…7814037167).
    The closes location we can manage is 9428992s to 7814037134s (sectors 9428992…7814037132).
    Is this acceptable to you
    Yes/No?
    Yes
    quit
  • End of partition 4 for the 3TB My Cloud is at 5860533134s

you must look what in your console displayd.

by me was it rm 9. it can certainly have a other number? but off the end off the table

rm is the command for “remove partition”

sorry for my english :wink:

i found my screenshot from the partition table


#22

Its cool I didn’t have 9 on my table, Just in allocated space …

I resized partition 4 in gparted and its now sorted


#23

look at my screenshot in the spoiler, i hope its helped you a little bit

in my case, is must delete partion 9 and then worked the tuturial by me


#24

best gude, works exactly as layed out, kudos added.

edit reply: i did initally try to get this guide done in virtualbox with moderate sucess but ended up with not all the disk partions showing up in virtual disk image of physical drive but the rest worked just fine. abandoned the idea and did it live, but having test run it in virtualbox made it seem less scary.


#25

Thx a lot! Worked perfectly as described.

I bricked my brand new wd my cloud 4TB while downgrading the firmware. i was quite nervous to disassable the device (and my computer). But everything went totally fine, the blue light is on, 3,9 TB shown as free space - and btw I have downgraded my firmware as well, so I can easyly use btsync - that was what I originally wanted to do…

:smiley:

Thx a lot!


#26

Hi everyone, looks like i’ve really screwed myself this time. I consider myself somewhat advanced at linux but would really need some serious help. i will keep it simple to the point.

I have an old WD cloud drive from late 2013 or early 2014. It was moded with several 3rd part apps on it etc. In the past i had bricked it but eventually fixed it and I had taked a partition backup of the raid partition that saved me a lot of trouble for future debrickings as i simply restored that backup to the two raid partitions of the drive and that fixed everything.

Now today i got another new WD cloud drive, same capacity of 3TB. I didnt care for warranty. I made sure this drive was on the same EXACT firmware. For whatever reasons that i dont want to get into, i decided that i will open up the new drive and restore the raid partitions from other drive’s image hence bringing over all my mods and suff… However the new drive is NOT booting. Its stuck at the white led.

i did notice two things. The hard disk inside though is WD RED, its differnet looking, which shouldnt matter. however the controller board that has the LAN port, power port, usb is different in shape and design.

Could that be the reason why the image of the old drive is not working on this drive?

please i really need some advanced help. I’ve managed to brick the nwe drive completely.

Heres the partition layout

EDIT: was able to fix it by using “dd” to copy over ALL partitons from the old wd drive to the new one.


Wd my cloud unbrick virgin image
#27

I’ve been working through this guide and it’s been very helpful so far. I’m still getting a red light however so I thought I would add to the conversation:

The initial problem I ran into after burning the disk image to the new hard drive was that the last partition on the disk was not fully utilizing all of the available disk space (since I used the 2TB disk image on a 3TB disk). I’ve since resized the last partition and I’m pretty sure everything should be good with my disk parition-wise. However, when I turn the My Cloud on I still get a red light. The My Cloud detection software does not see the drive on my network either. I’m also unable to reset the drive using the reset switch (the light does not flash at all during soft or hard resets).

Right now I’m attempting to SSH into the drive and see what I can do, however it doesn’t appear as though the drive is resolving to an IP address with my router. The TX light (orange) on the drive’s ethernet port is a solid orange too, not sure if that is a sign of anything specific. 

I feel like I’m very close to cracking the problem but I’m not sure where to go from here. I could attempt re-burning the disk image to the WD drive but I feel like i’d end up in the same situation.

Any suggestions?


#28

Thank you very much for this guide. Got my wdmc up and running again. 

Used a s-ata to usb first, but that didnt work… Maybe just incompatible adapter. 


#29

Will this work for a MyCloud 6TB?


#30

Good question… I don’t own a 6Tb, so I don’t have anything to test… Anything I say here is an educated guess. (And a risk to your hardware, and voids your warranty)

If the hardware is the same, (everything BUT the actual hard drive) I see no reason why this guide wouldn’t work.  You would need to calculate the size of partition correctly, of course… If you use the numbers for a 4Tb, for example, you’d have a cloud with only 4Tb usable…

For that matter, (again, an educated guess) I see no reason why replacing the stock Hard Drive with ANY properly partitioned drive wouldn’t work. Assuming comparable heat/cooling/etc, a larger drive should be possible. 


#31

as soon as WD red 6TB drives drop it price my plan is to mirror my 3TB drive to the 6TB one and just extend the last partition so mycloud will see 6TB and not the 3TB. But alas atm they are still around £200 and I still have about 500GB spare on my 3TB drive


#32

I’ve already said good bye to my warranty :slight_smile:

It was a MyCloud with the new WD Red 6TB hard drive and it got bricked.

I will be trying your guide, nad see how it goes.

The only part I probably need to play around with is the sector numbers like you said.

Will let you know how it goes…


#33

I came across this thread in a search for how to unbrick, worked like a charm. One question though, as I am new to the My Cloud device, should it initialize every time after I’ve done a shutdown and then power it back up or did I miss something in the re-imaging?


#34

I registered just so I could say THANK YOU!

I have a 4tb my cloud that I bricked by screwing up the apache and php config!

Your guide saved me!


#35

Hi first thank you for the guide it realy helps and accurate

I have some questions:

  1. Now that I have the new disk partitioned as instructed. when I restart - will it save my users, folders and permissions or do I have to redefine the thing?

  2. If I need to redefine is there a way to back up those b4 I replace the HD?

  3. If my 2T disk is OK I just want to upgrade to a 4T - can I simply use a cloning software (even sector by sector cloning) and just readjust the data partion to use the whole size?

Thanks in advance


#36

Hi,

Thank you to everybody taking time to post and answer questions here. 

I tried to unbrick my WD MyCloud 3Tb but it did not worked.  When I apply 2tb image and resize the partition 4, the device won’t boot at all. (Solid white led).  I found a 3tb image and tried it.  With this image, I hear some disk access, but the device reboots at every 45 seconds.  (solid white led, flash at every reboot).

I guess it’s a reboot since I left the device alone for 8 hours and still the same.  And also hearing the disk access, the ‘clicks’ are always the same, same interval between them, so I can guess the disk is accessing the same files again and again.

Any idea?

Thanks,

Eric


#37

I answered myself!

For those that may have the same problem, I formatted partition 4 (mkfs -t ext4 /dev/sdb4) and reinstalled in my device.

Now it boots up with blue light!

Thanks,

Eric Jalbert


#38

Hi, i’ve done unbrick as described for several times in case i have done something wrong and each time left it for day or more and still have only solid white led… Only blinks at connect to power. Any solution or ideas?


#39

Can you post your link to the 3TB image? I’d like to try using a different disk image than the one in this thread since I haven’t had much success.


#40

dmschulman wrote:

Can you post your link to the 3TB image? I’d like to try using a different disk image than the one in this thread since I haven’t had much success.

I have an image base on 250GB. See if you want to give it a shot.

NOTE: Not fully tested, but you can give it a try.

Just follow the steps for loading the 2TB image. Do share the result if you don’t mind.

https://drive.google.com/file/d/0B6-FmYB72q8KQmt1cWtobG9xd00/view?usp=sharing

Another video on how to open the case: https://www.youtube.com/watch?v=2_eW25LGXcI