GIT Server on My Cloud Mirror

Hello All -

While I saw some discussions a while ago, for setting up a GIT server on WD MyCloudMirror, I don’t find any more apps in WD App store portal for GIT. Has anyone used WD MyCloudMirror to setup a GIT Server and if so, could you please share the steps?

Thank you in Advance!

Hi there,

I have not tried this, lets see if another user can help you out with some tips and information on this matter.

Actually I found Sasmito Adibowo’s article here ( this blog very informative. I made so much of progress.

However, I am still stuck because of MyCloudMirror that I have only has OpenSSH v5 which is not accepting RSA. I am getting the following error -

“Unable to negotiate with no matching host key type found. Their offer: ssh-dss”

I tried all of the work-arounds I could get my hands-on like add RSA/PublicKey support in sshd.config. Nothing is working. Seems like the last resort is for me to update SSH in my WDMyCloudMirror to OpenSSH v7. Unfortunately I do not know how to do it. Kind of stuck at the moment.

I am very interested in this. Did you ever get things to work? I am stuck at not being able to install the app, however I do know a workaround for your ssh problem

This is how I ssh to my cloud…

ssh -oHostKeyAlgorithms=+ssh-dss sshd@MYCLOUDIP (replace MYCLOUDIP with your cloud’s IP)

Since this is impossible to remember I added this to my .bashrc file on my home PC. (I use cygwin for ssh)

alias cloud='ssh -oHostKeyAlgorithms=+ssh-dss sshd@MYCLOUDIP