Getting 'Access Denied' when trying to Initialize my Disk in Disk Management

Hello Guys,
My Ext HDD 1021 (1TB) has suddenly stopped showing. I’m using Windows 10.
when I’m opening Disk Management it asks me to Initialize it (“You must initialize a disk before Logical Disk Manager can access it”), when I’m clicking OK, it throws an “Access Denied” error (for both GPT and MBR options).
everything I tried doesn’t seem to work:

  1. I tried connecting it to other PCs
  2. I tried connecting as Admin
  3. I tried uninstall all the USB MASS Storage Device and reboot Windows

in the link below you can see the exact issue I’m facing with screenshots (but unfortunately without any solution in it):

any help will be be appreciated.

Thanks,
Elad

Most of the times, the error message “Access is Denied” indicates that there is some problem with the hard drive, which has made the hard drive inaccessible.

Here, I suggest you to check the below link which explains the methods to fix the Access is Denied issue:

Hope it helps!

Thanks Jose2020.
however, my drive isn’t visible in the File Explorer so I can’t change its security properties. I also tried downloading the “Stellar Data Recovery” software (as suggested in the link you added) but it’s not allowing me to do anything to the Disk.
anyway, thanks for trying to help.