Can't access error

Hi all,

I got a 3TB MyBook drive that I bought recently. it worked for a week or so but now I got a weird problem.
when I connect it to my PC I can hear the sound that windows is doing when connecting new device but I can’t see it under “My Computer”

so I opened up the disk management option in window 10 and then I see that the hard disk is showing there but as “uninitialized” drive.


when I try to initialize it I get the “Acess is denied” error


i read about some fixed regarding the “Access is denied” but they all happened when the drive was showing as a valid drive, unlike my situation

tried it in 2 different computers to eliminate USB port issue since I’ve upgraded my CPU and MB this week
I’m running windows 10

Any help would be appreciated

If the device is password protected then you will see this error. You can use WD Utilities to format the drive again. If it ask for password then you can type in any letter and try to unlock it 5 times, then it will ask you to format the drive. Remember all data on that drive will be lost.

thanks alot ! this worked for me