G-Speed Studio XL now working with my 2021 MacBook Pro M1 Pro Monterey

There are a few postings on this forum about G-Speed Studios not working (i.e., won’t show up in Finder) on 2021 MacBook Pro M1s running Monterey. I had that issue with my devices.

I found a workaround and I am now able to access my G-Speed Studio XL 24TB on my 2021 MacBook Pro M1 Pro running Monterey.

Basically, you have to:

(1) download the Promise Pegasus2 driver (R_MacDrv_V6_2_16)


(2) Change the security settings on the 2021 MacBook Pro startup disk to Reduced Security, “Allow user management of kernel extensions from identified developers”

After performing both of these steps, which included a reboot or two, I plugged the TB2 cable from my G-Speed Studio XL into the TB2/TB3 adapter dongle and plugged that into my 2021 MacBook Pro. In about 30 seconds (maybe less), the G-Speed Studio XL appeared in Finder and I was able to access all the files. Note: I did find the Blackmagic Disk Speed to be slower (but still workable, in my case).

Links provided to respective files and documentation below:

Note: For the Promise Pegasus2 driver (after accessing the link/page), scroll down to the “Compatibility” section and under Models, download the Pegasus2 Series driver. Install the downloaded package on your 2021 MacBook Pro.

macOS Big Sur Support - Promise Pegasus Compatibility List

Change security settings on the startup disk of a Mac with Apple silicon


I have tried this with no success. That was essentially the same steps I took to get the SSD Shuttles to work with the M1 iMac when it came out, but no luck with any of my machines (M1 13 MBP, M1 mini, M1 iMac, M1 16 MBP) all running Monterey.

Welshofer, really sorry to hear this isn’t working for you - it is very frustrating.

Maybe we can compare our system settings and possibly see a difference which might point out a fix for you?

Happy to give it a try, if you’d like.

For example, when I review my System Report, Controller, I see:

Boot Policy:
Secure Boot: Reduced Security
System Integrity Protection: Enabled
Signed System Volume: Enabled


I’m not thinking these are the only parameters to check. Just thinking out loud on parameters to compare, possibly.

In any case, best of luck to you - I do hope you get this resolved quickly/soon.

Hello @Alright4here , thanks for the tip, I also was able to make my G-Speed Studio 12TB to work on my new MacBook Pro 14’ Max processor and Monterrey with your instructions, just one reboot and all was working without problems after. Thank you.

I hope WD provide a final driver for G-Speed Studio, worry about loosing data

@Alright4here you’re my hero!
This workaround method saved my entire archive and finally let me get back to work after 2 months of messing around. For anyone else, this was my scenario.

Could not mount:
SanDisk Extreme Pro Portable SSD 4TB
G-SPEED Shuttle XL TB3
on Mac mini (M1, 2020)
iMac (i9, 2019)

Problems started with macOS Monterey and continued after updating to macOS Big Sur.
I was originally plugged into an OWC Thunderbolt 3 Dock and thought it might be an issue of not enough power through the Dock but the drives would not load when plugged directly into the computers either.
Finder wouldn’t find the external hard drive. Disk Utility options did nothing to help.

First tried installing Dock Ejector from OWC
*For Mac — Includes USB charge support driver. Probably a good idea to install every time on any computer using an OWC Dock but I’d had mine for so long I forgot about it when I upgraded from the old garbage can mac. Anyways, Dock Ejector didn’t solve the unmountable drive issue, but at least I’m ejecting other hard drives faster (and safer?) now without spinning the wheel of death.

Downloaded the PROMISE Pegasus2 Series Driver and used their very easy to follow installation guide (changing the System Extensions / Boot Policy / Security settings) as instructed.

BINGO! Everything works.

So I’ve used the Promise drivers and managed to get my drives to show up for a few hours to minutes each. Usually they end up un-mounting themselves, sometimes they just lock up the Mac. One of them no longer mounts at all.

I’d like Western digital to send me a pair of 32TB SSDs formatted in exFat (their suggestion) so I can attempt to copy my information off these dodgy drives. Otherwise I’d like a complete refund. This nonsense has gone on long enough. Close $20K worth of drives that are completely useless.

I’ve contacted Apple support and former colleagues there (I just left Apple last year after 26 years in product management) and neither set of folks are aware of a pending fix coming from Apple.

I have no functional driver from Western Digital, no functioning Drive Utility, and no path to making these things useful.

I’d like a response from Western Digital.

1 Like

I am in this camp. I have a new MacBook Pro with M1 Max running Monterey. I have a G Speed Studio XL 24TB array that previously was used on a 2013 Mac Pro. I now need to use it on this Mac Book but it will not appear in finder. I have performed every possible suggestion given on this forum and others I’ve found, and nothing works. Can someone please help!!???!

1 Like

One more tidbit. After performing the steps outlined above, I found that I additionally needed to install the Pegasus32 Series USB Filter Driver, which is available from Support - Download Center | PROMISE Technology

After this, my G-RAID SHUTTLE 4 from SanDisk Professional now appears on my MacBook Pro (13-inch, M1, 2020) running macOS Monterey Version 12.2.1.

any updates if it works now?

You are a star. Thank you for this solution - worked for me and I can now access Tb of necessary files :star: