G-Speed Shuttle XL and M1 MBP running MacOS Ventura

The driver shown on that page is the same one I’ve downloaded, but never gotten to work. I think the DEXT driver must be the key.

1 Like

The way that the “support” teams from WD just make s**t up is inexcusable and horrifying. I cannot fathom why people aren’t fired over this.

Here’s the latest response I got from them:

Dear Eli Israel,

Thank you for contacting Western Digital Customer Service and Support. My name is Simon N.

We apologize for any inconvenience this may have caused. We would like to update you on the compatibility of our G-Speed Software Utility with Thunderbolt 2 Model . We regret to inform you that at this time, there will not be a driver available for our Thunderbolt 2 model for M1 Macs as the G-speed shuttle thunderbolt 2 is a discontinued model. We understand that this may be disappointing news, and we apologize for any inconvenience this may cause.

However, we would like to inform you that if you are able to move the drive to an Intel Mac with Venture OS, the G-Speed Software Utility will work seamlessly with Thunderbolt 2.

If you have any further questions, please reply to this email and we will be happy to assist you further.

Simon N
Western Digital Service and Support
Support | Western Digital

How many ways can this go wrong?

  1. They misunderstood the problem. I was asking about the driver, not the software utility.

  2. They gave the wrong answer. According to others here, there IS a recent driver update.

  3. They gave a useless answer. Oh, you mean all I have to do is buy ANOTHER computer with a chipset that Apple no longer wants to continue with and THAT will solve my problem?

Like I said, how do people not get FIRED for this level of poor service?

In case it’s not clear, I’m planning to transition off of this device as soon as I can, and I will NEVER buy anything from WD again.

Incompetent wretches.

1 Like

I had a Speed Shuttle 4 on order when I read this thread . After reading this info I canceled the order, because it looks as if it’s not safe to use the Shuttle with M1 and Ventura. How WD / G Tech can mess up this bad is really sad. Also, even before I cancelled I already had a very bad experience with their customer support. I wanted to know if they sell the caddies for the 3.5inch HDDs for their Shuttles separately so I could swap discs easily and so on. I wasn’t too surprised when they told me they don’t. The guy told me I would only be able to get those if I had a warranty issue. I then wanted to know what would happen AFTER the warranty runs out and I needed a substitute for these caddies. He honestly told me I would then be unable to get these either. After that conversation I was already on the verge of cancelling my order, but now this whole Ventura issue was just too much. Goodbye WD, please let us know when you come off your high horse again. Until then hello OWC

Thanks! It works for G-Raid Shuttle 4 for Mac Ventura 13.1 with M1 chipset!

I tried going through all this. it did not work for me at all. Currently using 16" MBP M1Max in Ventura. When I loaded the utility program, it would open but no windows and my Shuttle XL and Studio XL would not mount. When I first got this computer this time last year, I was able to get them to mount in Monterey up until a week ago and they no longer worked in Monterey.

Worked perfectly for me on G-SPEED Shuttle XL Thunderbolt 2 (using Apple Thunderbolt 3 to Thunderbolt 2 adapter dongle) with MacBook Pro M2 Max (Ventura 13.4)


created this account to say thanks to @ryan1singer G-Speed Shuttle XL and M1 MBP running MacOS Ventura - #14 by ryan1singer
and this simply works as magic, I rolled back to FULL Security and all are still working, I cannot open G-RAID Software Utility but now it runs smoothly as well. basically all is working as expected and the disk speed is at full, I got a G Shuttle XL 80TB

but the only concerns is: since WD dropped G-Drive line and clearly not providing active support on this, and Promises seems are separating from WD/G-Drive and not a guarantee that they will keep supporting G-Drive in the future ( the drive I downloaded are not even G-Drive drivers, it’s Pegasus_DEXT drivers) it’s very uncertain that after how many days or how many OS updates this will become a plain brick unless you never upgrade your computer. but we are buying the RAIDs for the long terms storages… any thoughts on this everyone?