G-Raid Studio - Problems and solutions?


#1

Hi!

I have a G-Raid Studio 8TB that i’m having troubles with.

It’s formatted as EX-Fat and using a Thunderbolt 2 - 3 adapter (Apple) into an Asus X99 Thunderbolt 3 card.

Everything has been working for for a couple years but when I came back from vacation the drive is not being recognized.

When I have it plugged into the Windows machine with the adapter it’s always worked with the drive isn’t detected and doesn’t even spin up. (My guess is that my Thunderbolt 3 card is toast)

When I plug the drive into my mac laptop without the TB3 adapter and into a TB2 port the drive definitely spins up but doesn’t mount. I’ve tried to manually mount it but it doesn’t go. It’s recognized as an 8TB ExFat drive but is just unable to be mounted. The fact that drive spins up on my mac but not on the windows machine it’s always been used with makes me think it’s a windows hardware problem but i’m not 100% positive.

Does anybody have any insight as to how to get this to mount on the MAC computer?

If worst comes to worst and it’s not my TB3 card in my windows machine, can I somehow transfer these drives to another enclosure?

Any other help?

Thanks!


#2

Hi c0rpse,

We have exactly the same hardware and had the same issue. Now its fixed with help from Rydia (WDStaff). You can find the fix here:
2x G-Speed Studio XL and G-Raid no longer being recognized in Windows 10.

Also, dont forget to update Windows.
Good luck!