FTP LOGIN failed

Goodmorning everyone,
I have recently purchased a WD CLOUD EX2 ULTRA,
but I can’t interact with it via FTP access,
In the NAS settings under settings> network FTP access has been activated by me, in the Port forwarding menu both ports (20 and 21) have been configured and the same ports have also been opened in my modem
but when I connect through the FILEZILLA client it gives me the following error “Unable to establish data connection. ECONNREFUSED - Connection refused by server”

Also if I try to connect via FTP from the Windows Explorer included in windows it says “Cannot access the folder. Please verify that the file name is valid and make sure you have the necessary permissions to access the folder”

Could you help me?
Thank you in advance
Fabio

Hello,

Please refer to the following KBA article: How To Configure FTP Server Access on a My Cloud

I have OS5 since it was advertised and after that I setup ftp using it successfully.
However today I noticed the reported behavior.
No configuration change made.
WD version is 5.12.108
I did port scan but port 21 does not show open.
I even enabled sftp (port 990), but I could not see port 990 open either.
Not sure if it is a bug.
I couldn’t find files for older version to downgrade and test

Hello,

I opened case with WD.
They asked me to reinstall 3rd party Apps and follow the configuration guide
https://support-en.wd.com/app/answers/detail/a_id/4749

I had uninstalled all the Apps in WD device.
Restarted device.
FTP still not working, and port 21 still not open.

Then I disabled and enabled FTP option in Network settings. (I had already done this on my initial tshoot)

Then in Shares I disabled and enabled FTP and Applied change.

After that I could see port 21 open.

My opinion is that the last step in Shares solved the issue.

I hope this work for you as well.