FTP Connection Failed - WD MYCLOUD EX2 ULTRA

Hi to all,
it’s about one month that the FTP connection doesn’t work anymore. I need it for recording Reolink FTP camera on the NAS and one day it stopped working…
I’ve tryed also FileZilla and Windows to test the FTP connection to the NAS but also with this two methods the process fail.
I’ve tryed to use also the anonymous access to a folder but nothing changed.
Can someone help me?
Thank You

@DamiB Post up the extended error messages from FileZilla FTP client logs and what TLS version it’s set at.



Thank you

@DamiB The real logs from FileZilla

2021-03-10 20:02:18 11108 1 Stato: Connessione a 192.168.178.200:21…
2021-03-10 20:02:19 11108 1 Stato: Tentativo di connessione con “ECONNREFUSED - Connessione rifiutata dal server” non riuscito.
2021-03-10 20:02:19 11108 1 Errore: Impossibile collegarsi al server
2021-03-10 20:02:19 11108 1 Stato: In attesa di un nuovo tentativo…

Any news?

I have the same problem with same error.
WD version is 5.12.108
Not sure when the issue started. This version or previous.
I could not find previous version files to downgrade the device and test.
Port scan doesn’t show port 21 is open on device.
Even when enabled sftp (port 990), port scan didn’t show open 990 either.
It is really strange behavior that I could not find solution.

1 Like

Hello,

I opened case with WD.
They asked me to reinstall 3rd party Apps and follow the configuration guide
https://support-en.wd.com/app/answers/detail/a_id/4749

I had uninstalled all the Apps in WD device.
Restarted device.
FTP still not working, and port 21 still not open.

Then I disabled and enabled FTP option in Network settings. (I had already done this on my initial tshoot)

Then in Shares I disabled and enabled FTP and Applied change.

After that I could see port 21 open.

My opinion is that the last step in Shares solved the issue.

I hope this work for you as well.

Best Regards

Quick Questions:

  1. how are you determining if port 21 is open or not? IE: what tool are you using?
  2. Is this a Local LAN FTP connection to local IP or WAN connection through the network router?
  1. I am using Fing app in mobile.
    However there are also apps for desktop, and even online tools to check if port is seen open on public IP.

  2. Currently I am using only local LAN access. So test was done in LAN

@gtheolog Interesting. FTP Server and port should still be running and show as open regardless if any Share Access has been enabled. If you find yourself in this situation again, please collect the system logs before making any changes. How to Collect My Cloud System Logs

via SSH

root@MyCloudEX2Ultra ~ # netstat -tulpn | grep ftp
tcp 0 0 0.0.0.0:21 0.0.0.0:* LISTEN 17648/pure-ftpd (SE
tcp6 0 0 :::21 :::* LISTEN 17648/pure-ftpd (SE

I agree.

I disabled FTP option in Shared folders, keeping only FTP enabled at network settings. Port 21 was still open.

I assume something stuck and was seeing service not enabled.

@SBrown thank you for the extra info.

I hope our discussion will help subject creator to solve his issue.

INCREDIBLE!!! Now FTP is working perfectly for FileZilla and also for my IP CAMERAS. Thank you very much for helping me!!! I’ve only followed your suggestion step by step and now all is working correctly.

1 Like

I have the same problem since the release of v.105; however, it’s not clear from the thread what you did to re-establish FTP access to the EX2 from your security camera’s. Did you only have to disable FTP on the shares to re-establish FTP between cameras and EX2 (NAS)? Did you have to delete all the applications from the EX2 as well? Do you know if they have a ticket to fix this bug in their next release?

I have the same problem since the release of v.105; however, it’s not clear from the thread what you did to re-establish FTP access to the EX2 from your security camera’s. Did you only have to disable FTP on the shares to re-establish FTP between cameras and EX2 (NAS)? Did you have to delete all the applications from the EX2 as well? Do you know if they have a ticket to fix this bug in their next release?
[/quote]

Uninstalling Apps was tech’s suggestion, so I did that first.
The other two steps were my approach.
You can try steps reversed and see if there is any difference.
Otherwise run them from top like I did.
From my experience I suppose only last step will help (in Shares, disable and enable FTP), but not 100% sure.
I don’t know if they have it in mind to fix in next release.

1 Like

I’m on 5.21.104 on my EX2 and WD has still failed to fix this FTP problem. Turning the FTP shares “off” and then “on” works for about a minute and then all further attempts result in a server connection failure. I do think the developers need to upgrade their test scripts before putting these patches into production. I’ve since secured a Synology drive and it works like a charm with FTP so I think the EX2 is a brick now relative to FTP support.