Fix update process for firmware & smartware


I bought a 750GB external harddrive ( my book essentials) at the end of May, 2010.

I have been in 'phone and email ’ contact with WD staffers to try and fix a fundamental issue…that of update firmware and software for this Ext. HD…no success in updating either firmware OR software OR getting the smartware installed to even do the auto backup. I am now in “drag and Drop” mode which is working…but no use of Smartware.

I have a Windows Vista 32 bit o/s which is operating very well. The advice I get from WDJeremy is to adjust the settings in Windows to see if this works.

My suggestion to WD is for you to talk to your technical staffers and FIX what is wrong with the “firmware and Smartware update” process for “My Book Essentials”. 

Updating software with any other Software Co is not a problem…but for some reason, WD has big issues with updating its software for its users.

Please fix the problem so that the update process is as simple as any other software update…this is not rocket science…

WD did a masterful job at " marketing" the “easy to use” external HD using smartware…but it does not work for many a user after the initial backup…Please look at my file as I’m registered and there are a multitude attempts documented to fix the problem but without success.

Thanks for listening…Garry


Hi Garry,

I hear you man!  I just bought a WD MyBook Essential 1.5 Tb.  After finding out that the software backs up every dang thing that goes by your desktop, even unwanted temporary files (such as large raw/unedited video files that are not to be backed up), but does not let you delete any single file after it has been backed up…  (BTW: Smartware?  Oxymoron indeed!)

…I decided maybe the firmware / smartware update would fix that.  What kind of back-up system does NOT let you delete unwanted backed-up files, after all…?  A back-up system designed to fill itself asap so you need to go out and buy a new drive, I guess.

Anyway, after reading the thoroughly complicated 3 pages of instructions before updating, I did so.  Windows (vista) gave me a few crashed application messages and the WD “software updater” with the barbershop animation just kept going and going.  I gave it over an hour, and then figured something was wrong.  How long does it take to update low-level code on a hard drive?  Surely not an hour.

After rebooting, the drive was longer recognised, and Windows just kept asking for me to point it to the drivers, which of course I don’t have.  And a prize to anyone who has ever witnessed Windows find a driver by itself on the internet :wink:

Luckily enough for me, after running the firmware updater several times in a row with no result (it would not recognize anything plugged into the computer), in between bouts of pulling my hair out, after a while it strangely seemed to recognise something plugged in, yet it was unsure what it was, asking “MyBook or Passport?”.  Incredibly, it actually managed to fix whatever went wrong and finish the firmware upgrade.  This, after having rebooted both the computer and the MyBook.  I consider myself to be extra lucky today.

I have still not tried out the updated software to see if I can actually DELETE unwanted files from backups, but my take on this piece of hardware is (MyBook Essential)… 2 thumbs down.  Find some other solution for your backups.  Their marketing is excellent, but the product **bleep**.  WD should just stick to making hard drives and leave software to someone else (but maybe not Microsoft :wink:

By the way, the on/off switch has absolutely no tactile feedback, it’s like pushing into a rigid rubber cushion.  Since the drive doesn’t like to be switched off manually, I actually managed to break the on/off switch when waiting for it to react, with just the pressure of my index finger reaching 'round the back of the unit.  I would take it back to yell a little and get my money back, but the broken button actually gives better feedback on whether it is being pressed or not.  And in the worst case, I have a drag 'n drop 1.5 Tb HD to make manual backups on.

Yeeehaw!  A very disappointed customer, to say the least.


I have to agree with both of you as I have the same problem with 2 of  my WD’s. Recently my son came over and pluged my drives into his laptop and they worked fine, then he pluged them back into my pc and they worked …until reboot…then they didn’t work again!!!





A lot of people bought into the Windows 8.1 which was the promise of everything.   Most effecting me was it could not read the drives behind the two WD Live and WD TV Media player.   By default, Windows 8 set up a HOMEGROUP  which wiped out WORKGROUP .

This HOMEGROUP had MS safety features built into it that would not allow us to see our hard drives!

Complaints went into WD support and not knowing better they were advised to reboot thier WD units and reformat drives.

I worked hard with MS on this issue and about an hour ago they put an update into my machine changing the HOMEGROUP back to WORKGROUP.   

As of now, everything is back as it should be.   At some point I would think a rework of HomeGRoup will see an update going the other way hopefully this time it will work right.

Regards all.