Firmware upgrade strangeness

My daughter just bought this WD TV Live Plus for me and there seems to be many problems with it. Hard to believe a manufacturer would put out a product with so many problems! Especially at this cost!

First, tried to upgrade it’s firmware, already shows that it has 1.03.39B out of the box. When I loaded the upadate onto the drive it recognizes it, but says it is update 2.03.39B, did the update anyway, did not fix the Network share problem, so after reading many things, I tried to roll back to 1.03.29. It was recognized as the same 2.03.39b. Those “2”'s are not a mistake on my part, that is what it said. Did the rollback anyway thinking that they purposely made it that way so it could be rolled back, but the system would think it was an upgrade. But very strange that none of the documentation says this.

My biggest question is, why did this indicate it had the beta formware out of the box? Is it really doing the upgrades or am I having some problem and should take it back to the store before it’s too late.

Just a note on other problems I’ve noticed that I hope are to be fixed:

Will not recognize new files without rebooting (files transfered to usb drive while active)

Brings up some WMV music files as Videos when connected with laptop as a media server.

The network share cannot get past the password, tried every combination of sharing I could imagine, called support and they told me to use the Media server and I should turn my firewall off too(should’nt they have settings to go through local firewall, BTW, Media server worked fine through firewall, that wasn’t a problem), that it wasn’t meant to share files on another computer, yet the icon for it is a picture of a laptop ? That’s got to be BS! Had my system a files so open and shared that I was worried about it and it’s a home system not internet connected although I was hoping to do a VPN to the internet.

Anyway, should I return it because of the firmware thing? If I can upgrade it later, I can deal with the other problems untill they get them fixed, but not if it’s having a problem upgrading the firmware.



First, what firmware upgrade did you try?   There aren’t any Non-Beta firmware updates for the Live Plus.

What network share problem are you trying to fix?   As far as I know, there aren’t any “Bugs” affecting network shares.

It doesn’t have Beta firmware out of the box.  Why do you think it does?

 Will not recognize new files without rebooting (files transfered to usb drive while active)

Bug or Limitation, I agree with you about that behavior.

Brings up some WMV music files as Videos when connected with laptop as a media server.

That would be a bug with your media server, not the Live.

 The network share cannot get past the password, tried every combination of sharing I could imagine

What version of Windows are you using?

It had said it had firmware 1.03.39B out of the box, That’s what came up when I it recognized the beta that I dowloaded from here What was strange is that it said the firmware that I put on the drive was 2.03.39B. The when I rolled back to the firmware I also got from that site, the firmware numbers were the same, the rolled back one, 1.03.29, which was on the drive, it said again that it was 2.03.39B, and the one on that was already installed was 1.03.39B. When I finished the roll back, said it was still 1.03.39B.

I’m using Windows 7 Home Premium, connecting wireless through a router with the WD live plus connected to the router via network cable.

As far as the shares, I’ve seen more references on here to the same problem and I’ve seen conflicting answers from WD, such as using or not using Homegroups, changing the network to a work network, etc. If it did not have problems, they would not be providing workarounds for Win 7.

I can’t get past the username password, no matter what I do. I’ve got windows set not not password protect shares, I’ve got shared files share to everyone, I’ve even tried setting up another user on my system just for the WD and using that username password. I’ve used homegroups, changed network to work network, and on and on. Still says username password is incorrect and goes no farther.

I don’t know why you would have had 1.03.39B out of the box, unless someone returned a unit they had already upgraded, and then you bought a return.   It’s happened before; several people bought a Live+ only to find a LIVE on the box (not a Live+) because someone bought a Live+ and then returned their LIVE, basically STEALING the Live+.

I just downloaded the correct package, and I’m thinking you’re not reading the numbers right.

The BETA is 1.03.39.   The 1.03.39_BETA ROLLBACK takes you back to 1.03.29.

As to why you see 2.03.29, That’s how ROLLBACK works.  In the ROLLBACK package, They substitute a HIGHER than real-value to “Fake” the WDTV into thinking that the firmware is NEWER than what’s installed instead of OLDER.   And once the Roll-back install is complete, if you don’t remove the USB key, it will keep saying there’s newer firmware (because the 2.03.29 is a HIGHER version number than what’s there.)

If the installation package had said the Rollback firmware was 1.03.29, the WD would have ignored it, because that version number is EARLIER than what’s already installed.

It’s just a bit of trickery.   Download the packages again and look inside the .VER file and you’ll see the “Faked” version number, but the BIN and FFF files are indeed the exact same as that in the original load.

I don’t know what WD Telephone or E-mail Support may have told you, but I’m pretty sure none of the WD-Staff here on the community told you to use HomeGroups…  If you find a post that says that, please link it here so I can read it in context.  

I’ve helped dozens of users here troubleshoot problems with Windows Networks.   In 100% of the cases, the problem was something on their network OTHER than the WDTV.   I can dang near guarantee you that the problem you’re experiencing is NOT an issue with the WDTV, it’s an issue with your computer(s) or some other piece of hardware on your network.

As to why you’re getting an Invalid User error, It sounds to me like you have the Windows Live Sign-In assistant (or some other Microsoft Live product) installed.

That’s a known issue, and it’s technically not a WD BUG, it’s a change in how microsoft authenticates shares.  It’s all explained in the FAQ here:

in sections 2B,

… and for a technical description of the Windows Failure to Authenticate issue, read this post: